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IT Essentials 5.0
10.3.1.8 Lab - Configure a Windows 7 Firewall

Print and complete this lab.

In this lab, you will explore the Windows 7 Firewall and configure some advanced settings.

Recommended Equipment

e Two computers directly connected or connected through a hub or switch
e Windows 7 installed on both computers

e Computers are in the same workgroup and share the same subnet mask

Step 1
For computer 1, right-click on the desktop, select New > Folder.

View »
Sort by »
Refresh

Paste
Paste shortcut

New »

Folder
Shertcut

|

B8 Screen resolution
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; Gadgets Bitmap image

Contact

Perzonalize

!ﬂ!

Journal Document
WinRAR archive
Rich Text Document
Text Document
WinRAR ZIP archive

Briefcase

© e e N

Name the folder Cisco.

Right-click on the Cisco folder then select Share with > Advanced sharing > Advanced Sharing.

The “Advanced Sharing” window opens.
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{. Cisco Properties =]
1 General ! Sharing ‘ Security I Previous Versions [ Customize
- 1
Network File and Folder Sharing | Advanced Sharing S
Cisco
1 Not Shared [¥] Share this folder
Network Path Settings
Not Shared Share name:
Share Cisco

Advanced Sharing — ——

Set custom penmissions, create | Limit the number of simultaneous users to: 20

advanced sharing options.

@) Advanced Sharing...
Password Protection
People without a user account g
can access folders shared with

To change this setting, use the
OK %J [ Cancel Apply

- -

Share the folder, use the default name Cisco.

Comments:

From computer 2 click Start > Control Panel > Network and Sharing Center > Network icon.

Double-click computer 1.

e

@uv"' » Network » JOHN-PC » v [ 49 |[ search sorn-pC 2|
File Edit View Tools Help

Organize » Network and Sharing Center View remote printers g= v [ 'C
. ‘ Cisco
s+ Libraries | Share h

a3 = Share

/=] Documents I 2

& Music - 7

: 1 #2 Shared Printer

k=| Pictures =7

= pi | 2

E Videos

‘ XP Folder

& Homegroup S e

L G nnmialine

.A. 3 items

Can you see the shared folder Cisco?

Note: If you answered no, ask the instructor for help.
Close Network.

Note: Use computer 1 for the rest of the lab unless otherwise stated.
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Step 2
Navigate to the Windows 7 Firewall:

Click Start > Control Panel > System and Security > Windows Firewall.

(=] =]
n v’ﬂ <« System and Security » Windows Firewall v | & ‘ | Search Control Panel pel |
) ) y 2
File Edit View Tools Help
®
Contrel Panel Home : ; % y
Help protect your computer with Windows Firewall
Allow 2 Rrogeam or feature Windows Firewall can help prevent hackers or malicious software from gaining access te your
through Windows Firewsall computer through the Internet or a network.
® Change notification settings How does a firewall help protect my computer?
# Turn Windows Firewall on or What are network locations?
off -
- | A mrivate) r A nr (A
) Restore defaults . 0 Home or work (private) networks Connected (4
# Advanced settings Networks at home or work where you know and trust the pecple and devices on the network
Troubleshoot my network
Windows Firewall state: On
Incoming connections: Block all connections to pregrams that are not
on the list of allowed programs
Active home or work (private) networks: ',:I\ BlackBear
Netification state: Netify me when Windows Firewall blocks a new
pregram
Action Center - -
W3 p. e A nr v
Netwptd et Sharo Gerfer l a Public networks Not Connected

The Firewall indicator shows the status of the firewall. The normal setting is “On”.

In the space below, state the benefits of Windows Firewall.

Step 3
Click Allow a program or feature through Windows Firewall.
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@O'" <« System and Security » Windows Firewall v | s l | 5

File Edit View Tools Help

Contrel Panel H i i .
oot Help protect your computer with Windows Firewall

Allow 2 program or feature Windows Firewall can help prevent hackers or malicious software from gaining access to your

through Windows Firewall{b computer through the Internet or a network.
) Change notification settings How does a firewall help protect my computer?
# Turn Windows Firewall on or What are network locations?

off

l ‘@ Home or work (private) networks Connected (&)

#) Restore defaults

# Advanced settings Networks at home or work where you know and trust the pecple and devices on the netwerk

Troubleshoot my netwerk
Windows Firewall state: On

Incoming connections: Block all connections to programs that are not

on the list of allowed programs

Active home or work (private) networks: =3 BlackBear
Notification state: Notify me when Windows Firewall blocks a new
See also program
Action Center - —
( H (<)
Network and Sharing Center l @ Public networks Not Connected (¥)

Step 4
The “Allowed Programs” window opens.

@-Ovlﬂ « Windows Firewall » Allowed Programs

File Edit View Tools Help

Allow programs to communicate through Windows Firewall
To add, change, or remove allowed programs and ports, click Change settings.

gram to communicate

Name Home/Work (Private)  Public
[B| BranchCache - Content Retrieval (Uses HTTP)

[ BranchCache - Hosted Cache Client (Uses HTTPS)
[OBranchCache - Hosted Cache Server (Uses HTTPS)
[BranchCache - Peer Discovery (Uses WSD)

[ Connect to a2 Network Projector

Core Networking

[ Distributed Transaction Coordinator

File and Printer Sharing

HomeGroup

[JiSCSI Service

[JKey Management Service

[ Media Center Extenders

% Change settings

Allowed programs and features:

m

-

O0000O0OxO0OO0OOfs

EDDDHHDHDDDDD

Remove

[ Allow another program... ]

[ OK ][ Cancel ]

Programs and services that Windows Firewall is not blocking will be listed with a check mark.
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You can add applications to this list. This may be necessary if your customer has an application that requires

outside communications but for some reason the Windows Firewall cannot perform the configuration

automatically. You must be logged on to this computer as an administrator to complete this procedure.

Click What are the risks of allowing a program to communicate?.

The “Windows Help and Support” window opens.

=

: @ Windows Help and Support @
&) & @ g;, il 3\:% Ask Opticns

’ Search Help pl

What are the risks of allowing programs through a firewall?

When you add a pregram to the list of allowed programs in a firewall, or when you open a firewall
port, you allow a particular program te send informaticn to or from your computer through the
firewall. Allowing a pregram to communicate through a firewall (sometimes called unblocking) is like
punching a hole in the firewall.

Each time you open a port or allow a program to communicate through a firewall, your computer
becomes a bit less secure. The more allowed programs or open ports your firewall has, the more
oppoertunities there are for hackers or malicious software to use one of those openings to spread a
worm, access your files, or use your computer to spread malicious software to others.

It's generally safer to add a program to the list of allowed programs than to cpen a pert. If you open
a port, it stays open until you close it, whether or not a program is using it. If you add a program to
the list of allowed programs, the "hole" is open only when needed for a particular communication.

To help decrease your security risk:

e Only allow a pregram or cpen a port when you really need to, and remove programs from the
list of allowed programs or close ports that you no lenger need.

e Never allow a pregram that you don't recognize to communicate through the firewall.

& Meore support options
1M Offline Help «

=

Creating too many exceptions in your Programs and Services file can have negative consequences. Describe

a negative consequence of having too many exceptions.

Close Windows Help and Support window.

Step 5
From computer 1:

Click on “Allowed Programs” window so it is active.

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.

Page 5 of 11



IT Essentials

Chapter 10 - Lab

@uv’o <« Windows Firewall » Allowed Programs v |‘1 [ ‘ Search Control Panel yel [

File Edit View Tools Help

Allow programs to communicate through Windows Firewall
To add, change, or remove allowed programs and ports, click Change settings.

What are the risks of allowing a program to communicate? % Change settings

Allowed pregrams and features:

Name Home/Work (Private}  Public *
[OBranchCache - Content Retrieval (Uses HTTP)
[OBranchCache - Hosted Cache Client (Uses HTTPS)
[OBranchCache - Hosted Cache Server (Uses HTTPS)
[dBranchCache - Peer Discovery (Uses WSD)

[ Connect to a Network Projector

Core Networking

[ Distributed Transaction Coordinator

B File and Printer Shaiing 0 O]
HemeGroup

[JiSCSI Service

[JKey Management Service
[0 Media Center Extenders

n

E0mO0O0O00O0

1

O000OmI0ORO0O000

EDDDI

To turn off an exception, remove the check mark from File and Printer Sharing > OK.

From computer 2:
Open the network connect to computer 1.

Click Start > Control Panel > Network and Sharing Center > Network icon.
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& Homegroup

1M Computer
&, Local Disk (C:)

m

4 Media Devices (2)

B y B

] )

BROOKS-1  MACBOOK

A11247F: -PRO: John:
Brooks:

[= =] =]
’\JU |G‘§ » Network » v| >4 H Search Network ,0’
File Edit View Tools Help
Organize » Network and Sharing Center Add 2 printer  » sy v [ @l
: 4 Computer (5)
~a Libraries
M NN N NN
J) Music NS CEaS Le NS NS
(&) Pictures BROOKS-1 COMPUTE JOHN-PC NPI2B2F19  SHAWNA-L
: Al1247F R2 APTCP
B videos

Rawmeoicable Dicl (F.)

| Network Errer

A '-,‘7"." See details
=

s

Windows cannot access \\JOHN-PC

Check the spelling of the name. Otherwise, there might be a problem with your network. To
G‘! try to identify and resclve netwerk problems, click Diagnose.

XS

[ Diagnose J[ Cancel ]

Can you connect to computer 1?

From computer 1:

To turn on an exception add a check mark to File and Printer Sharing > OK.

From computer 2:

Refresh Network screen and connect to computer 1.
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(&

. | 3items

v|"'| S

View remote printers

@_Ov',-;\ » Network » JOHN-PC »
File Edit View Tools Help
Organize » Network and Sharing Center
: o Cisco
a Libraries ' |
5 4 Share
%) Documents — [T h
Jﬁ Music £
d = Shared Printer
Pictures E @
Videos
, XP Felder
1
i% Homegroup Cay Share
1™ Computer 2

Lt
[

Can you connect to computer 1?

Log off computer 2. Use computer 1 for the rest of the lab.

Step 6

Click Start > Control Panel > System and Security > Administrative Tools > Windows Firewall with

Advanced Security > Inbound Rules.

Firewall with Ady d Security

’omu

File

e

Action

View Help

&3 Inbound Rules

Outbound Rules

i Connection Security Rules
B, Monitering

Name

@Ccre Networking - Time Exceeded (ICMPv6-In)
. Distributed Transaction Coordinator (RPC)

@ Distributed Transaction Coordinator (RPC)

. Distributed Transaction Coordinator (RPC-EPMAP)
. Distributed Transaction Coordinater (RPC-EPMAP)
. Distributed Transaction Coordinator (TCP-In}

. Distributed Transaction Coordinator (TCP-In)

V _ File and Printer Sharing (Echo Request - ICMPv4-In)
.File and Printer Sharing (Echo Request - ICMPv4-In)
@File and Printer Sharing (Echo Request - ICMPv4-In)
@File and Printer Sharing (Eche Request - ICMPvE-In}
.Fiie and Printer Sharing (Echo Request - ICMPv6-In)
.File and Printer Sharing (Echo Request - ICMP6-In}
.File and Printer Sharing (LLMNR-UDP-In}

@File and Printer Sharing (LLMNR-UDP-In)

‘File and Printer Sharing (NB-Datagram-In)
@ File and Printer Sharing (NB-Datagram-In})
@File and Printer Sharing (NB-Datagram-In)

. File and Printer Sharing (NB-Name-In)
<[ u |

] [0 | 3

Group
Core Networking

Distributed Transaction Coe...
Distributed Transaction Coo...
Distributed Transaction Coo...
Distributed Transaction Coo...
Distributed Transaction Coo...
Distributed Transacticn Coo...

File and Printer Sharing
Disable Rule

Cut

Copy
Delete

Properties

Help
File and Printer Sharing
File and Printer Sharing

Profile
All
Domain
Private...
Domain
Private...
Demain
Private...
Private
Demain
Public
Private
Demain
Public
Demai...
Private
Demain
Public
Private
Public

» Windows Firewall with Advanced ! [STRSE EI1 =5

Actions
Enabled Action  *
Yes Allow
fo Alow T Filter... »
No Allow [ ¥
No Allow !i‘ Y Filter... »
Ne Allow Y Filter... »
Neo Allow View »
No Allow
Yes Allow 6} Refresh
No Allow iz Export..
No Allow ﬂ Help
Ves Allow
No Allow VFiIeandPr... -
Ne Allow ¥ Disabl...
No Allow #‘ Cut
Yes Allow By Copy
Ne Allow
No Allow K Delete
Yes Allow [E] Prope...
No Allow > 52 n Help

Opens the properties dialog box for the current selection.
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Expand the window so you can see the full name of the Inbound rules. Locate Files and Printer Sharing (Echo
Request — ICMPv4-In).

Right-click on the rule and select Properties > Advanced tab > Customize.

File and Printer Sharing (Echo Request - ICMPv4-In) Properties
‘ General | Programs and Services Computers ‘
| Protocols and Ports l Scope Advanced | Users |

Profiles
L Specify profiles to which this rule applies.
=5 [ Domain
[¥] Private
[T Public
Interface types
T Specfy the interface types to which this -
-~ rule applies.
Edgetrave Customize Interface Types

- z
e A This rule applies to connections on the following interface types.

[ @ Allinterface types

(0) These interface types:

Leammoref | oam more about interface types

[ OK %J [ Cancel

[ 0K ] [ Cancel ] Apply

The Advance tab displays the profile(s) used by the computer and the “Customize Interface Types” window
displays the different connections configured for your computer.

Click OK.
Click Programs and Services tab.

The “Customize Service Settings” window opens.
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File and Printer Sharing (Echo Request - ICMPv4-In) Properties | =37
Protocols and Ports [ Scope ] Advanced ] Users
et ’ Programs and Services i Computers
Programs
@] (© oot ot e s
Services
7 Specify the services to which this nule
s>, applies.
-
Custemize Service Settings
Apply this rule as follows:
Name Short Name S
|l
S, ActiveX Installer {AxinstSV) AxInstSV -
£, Adaptive Brightness SensrSve
% Application Experience AelookupSve
< Application Identity AoplDSve
¢, Application Information Appinfo
¢ Application Layer Gateway Service ALG
S Application Management AppMamt
%, Background Intelligent Transfer Service BITS
‘S Base Filtering Engine BFE i
Leam more about these settings
Y

In the space below, list the short name of four services that are available.

Click Cancel.

Step 7
There are many applications that users do not normally see that also need to get through the Windows
Firewall to access your computer. These are the network level commands that direct traffic on the network

and the Internet.

Click Protocols and Ports tab. For the ICMP settings, click the Customize button. You will see the menu
where ICMP exceptions are configured.
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Customize ICMP Settings

Apply this rule to the following Intemet Control Message Protocol (ICMP)
connections:

This ICMP type:
Type: 0 Code: Any

Leam more about ICMP settings

In the example here, allowing incoming echo requests is what allows network users to ping your computer to
determine if it is present on the network. It also allows you to see how fast information travels to and from

your computer.

In the space below, list the Specific ICMP types.

Close all windows.
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