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IT Essentials 5.0 
5.2.2.4 Lab - Advanced Installation of Windows Vista 
 
Introduction 
 
Print and complete this lab. 
 
In this lab, you will install a Windows Vista operating system by using an answer file for automation. You will 
customize partition settings and create an Administrator account and User accounts.  

Recommended Equipment 
The following equipment is required for this exercise: 

• A computer with a new installation of Windows Vista 
• Windows Automated Installation Kit (AIK) installation media 
• Windows Vista installation media 
• A blank, formatted floppy disk or a USB flash drive 

 
Step 1 

Ask the instructor for the following required information for the answer file: 
  
Regional and language settings __________________________________________ 
 
Windows Vista product key ______________________________________ 
 
Partition sizes: Primary ___________ Logical 1 ___________ Logical 2 ___________ 

         
Administrator account: User name _________________________________________ 
 

        Password ___________________________________________ 
 
User account: User name ________________________________________________ 

 
          Password _________________________________________________ 

 
Computer name _______________________________________________________ 
 
Registered organization _________________________________________________ 
 
Registered owner ______________________________________________________ 
 
Time zone ____________________________________________________________ 

 
Step 2 

Log on to the computer as Administrator.  
 
Insert the Windows Automated Installation Kit (AIK) DVD in the DVD-ROM drive.  
 
When the “AutoPlay” window opens, click Run StartCD.exe. 
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The “Welcome to Windows Automated Installation Kit” window opens. 
 

 
 
Click Windows AIK Setup. 
 
When the “Setup Wizard” opens click Next.  
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Select I Agree to license terms and then click Next. 
 

 
 
For the “Select Installation Folder” screen, keep the default settings and click Next. 
 

 
 
Click Next to confirm and start the installation. 
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When the “Installation Complete” screen appears, click Close. 
 

 
 
Click Exit. 
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Step 3 
Create a folder called Vista_Installation at the root of C:. Example: C:\Vista_Installation. 
 
Insert the Windows Vista media in the appropriate drive.  
 
Close the “Install Windows” window if it opens. 
 
Navigate and copy install.wim from the Windows Vista installation media to C:\Vista_Installation. 
 
Note: The install.wim file is 2.6GB and may take several minutes to copy. 
 

 
 

Step 4 
Start > All Programs > Microsoft Windows AIK > Windows System Image Manager.  
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Step 5 
The “Windows System Image Manager” window opens. 
 

 
 
Right-click Select a windows image > Select Windows Image. 
 
Browse to C:\Vista_Installation > install.wim > Open. 
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Select Windows Vista BUSINESS > OK. 
 

 
 
Click Yes > Continue. This may take several minutes. 
 

 
 
A catalog file is generated in the “Windows Image” area.  
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Right-click Create or open an answer file > New Answer File. 
 

 
 
A new answer file is created in the “Answer File” area. 
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To name the file select the root node Untitled. 
 
Click File > Save Answer File > name the file autounattend. Make sure the Vista_Installation folder is 
selected then click Save. 
 
Note: It is important to name the file autounattend as Vista will only search for that file name when 
performing an unattended installation.  
 

 
 

Step 6 
In the “Windows Image” area, expand Components. 
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Note: The name of the components will have a prefix and suffix attached, for example: x86_Microsoft-
Windows-International-Core-WinPE_6.0.6000.16386_neutral. The prefix is x86 and the suffix is 
6.0.6000.16386_neutral. For simplicity, the prefix and suffix will be left out in the lab instructions. 
 
Right-click Microsoft-Windows-International-Core-WinPE > Add Settings to Pass 1 windowsPE. 
 

 
 
Notice that Microsoft-Windows-International-Core-WinPE has been added to the “Answer File” and 
“Properties” areas. 
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Select Microsoft-Windows-International-Core-WinPE in the “Answer File” area. In the “Microsoft-
Windows-International-Core-WinPE Properties” area type the language settings provided by your 
instructor in the following locations: InputLocale, SystemLocale, UILanguage, UILanguageFallback, and 
UserLocale. For example: en-us. 
 

 
 
Note: Place the curser next to a setting in the “Properties” area and press the F1 key to view the 
Windows Help file for the setting. Supported regional and language settings are located here: 
http://technet.microsoft.com/en-us/library/cc722435(WS.10).aspx. 
 
In the “Answer File” area expand Microsoft-Windows-International-Core-WinPE > select 
SetupUILanguage. In the “SetupUILanguage Properties” area, type the language settings provided by 
your instructor in the UILanguage location. For example: en-us. 
 
Confirm OnError is selected for WillShowUI. 
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Step 7 
In the “Windows Image” area, locate and expand the component Microsoft-Windows-Setup > right-click 
UserData > Add Setting to Pass 1 windowsPE. 
 

 
 
Select UserData in the “Answer File” area. In the “UserData Properties” area, click in the box to the right 
of AcceptEula > true.  
 

 
 
In the “Answer File” area, expand UserData > ProductKey. In the “ProductKey Properties” area, click in 
the box to the right of Key and enter the Windows Vista product key provided by the instructor.  
 
Click in the box to the right of the WillShowUI > Never. 
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Step 8 
In the “Windows Image” area, locate and expand component Microsoft-Windows-
Setup\DiskConfiguration > right-click Disk > Add Setting to Pass 1 windowsPE. 
 

 
 
Select Disk in the “Answer File” area. In the “Disk Properties” area, click in the box to the right of DiskID 
and type the number 0. Set WillWipeDisk to true. 
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In the “Answer File” area, expand Disk[DiskID=“0”] > right-click CreatePartitions > Insert New 
CreatePartition. 
 

 
 
Add three more CreatePartition objects, for a total of four objects.  
 

 
 
Select the top CreatePartition in the “Answer File” area. In the “CreatePartition Properties” area, set the 
following values: Extend = false, Order = 1, and Type = Primary. For Size, use the primary partition size 
provided by the instructor. For example: Size = 15000. 
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Notice that the newly configured partition moves to the bottom of the four CreatePartition objects. 
 
Select the top CreatePartition in the “Answer File” area. In the “CreatePartition Properties” area, set the 
following values: Extend = True, Order = 2, and Type = Extended. 
 

 
 
Select the top CreatePartition in the “Answer File” area. In the “CreatePartition Properties” area, set the 
following values: Extend = false, Order = 3, and Type = Logical. For Size, use the logical 1 partition size 
provided by the instructor. For example: Size = 5000. 
 



IT Essentials Chapter 5 Lab 

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 16 of 27 

 
 
Select the top CreatePartition in the “Answer File” area. In the “CreatePartition Properties” area, set the 
following values: Extend = false, Order = 4, and Type = Logical. For Size, use the logical 2 partition size 
provided by the instructor. For example: Size = 5000. 
 

 
 
In the “Answer File” area, right-click ModifyPartitions > Insert New ModifyPartition. 
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Add two more ModifyPartition objects, for a total of three objects.  
 
Select the top ModifyPartition in the “Answer File” area. In the “ModifyPartition Properties” area, set the 
following values: Action = AddListItem, Active = true, Extend = false, Format = NTFS, Label = 
Vista_Business, Letter = C, Order = 1, and PartitionID = 1. 
 

 
 
Select the top ModifyPartition in the “Answer File” area. In the “ModifyPartition Properties” area, set the 
following values: Action = AddListItem, Active = false, Extend = false, Letter = E, Order = 2, and 
PartitionID = 2. 



IT Essentials Chapter 5 Lab 

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 18 of 27 

 

 
 
Select the top ModifyPartition in the “Answer File” area. In the “ModifyPartition Properties” area set the 
following values: Action = AddListItem, Active = false, Extend = false, Letter = F, Order = 3, and 
PartitionID = 3. 
 

 
 
In the “Windows Image” area, locate and expand component Microsoft-Windows-
Setup\DiskConfiguration\ImageInstall\OSImage\InstallTo > right-click InstallTo > Add Setting to 
Pass 1 windowsPE. 
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Select InstallTo in the “Answer File” area. In the “InstallTo Properties” area, set the following values: 
DiskID = 0 and PartitionID = 1. 
 

 
 

Step 9 
In the “Windows Image” area, locate and expand component Microsoft-Windows-Shell-
Setup\UserAccounts\LocalAccounts > right-click LocalAccount > Add Setting to Pass 7 
oobeSystem. 
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In the “Answer File” area, right-click LocalAccounts > select Insert New LocalAccounts. 
 

 
 
You should now have two LocalAccounts objects.  
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Setup an Administrators account. 
 
Select the top LocalAccount in the “Answer File” area. In the “LocalAccount Properties” area, type the 
DisplayName and the Name provided by your instructor. Example: John and John M. 
 
Type Administrators for the Group. 
 

 
 
Expand LocalAccount[Name=“John M”] > Password. In the “Password Properties” area, type the 
password provided by your instructor in the Value setting. Example: Pa$$w0rd. 
 

 
 
Set up a User account. 
 
Select the top LocalAccount in the “Answer File” area. In the “LocalAccount Properties” area, type the 
DisplayName and the Name provided by your instructor. Example: Nathan and Nathan W. 
 
Type Users for the Group. 
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Expand LocalAccount[Name=“Nathan W”] > Password. In the “Password Properties” area, type the 
password provided by your instructor in the Value setting. Example: Pa$$w0rd. 
 

 
 

Step 10 
In the “Windows Image” area, locate and right-click Microsoft-Windows-Shell-Setup > Add Setting to 
Pass 4 specialize. 
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Select Microsoft-Windows-Shell-Setup in the “Answer File” area below component 4 specialize. In the 
“Microsoft-Windows-Shell-Setup Properties” area, type the ComputerName, RegisteredOrganization, and 
RegisteredOwner provided by your instructor. Example: Computer1, Cisco, and John. 
 

 
 
Expand Microsoft-Windows-Shell-Setup in component 4 specialize of the “Answer File” area. Locate 
and select Themes. In the “Themes Properties” area, set the following value: DefaultThemesOff = false. 
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Step 11 
In the “Windows Image” area, locate and expand component Microsoft-Windows-Shell-Setup > right-
click OOBE > Add Setting to Pass 7 oobeSystem. 
 

 
 
Select Microsoft-Windows-Shell-Setup in the “Answer File” area below component 7 oobe System. In 
the “Microsoft-Windows-Shell-Setup Properties” area, type the time zone in the TimeZone setting, 
provided by your instructor. Example: TimeZone = Pacific Standard Time. 
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Select OOBE in the “Answer File” area. In the “OOBE Properties” area, set the following value: 
NetworkLocation = Work and ProtectYourPC = 3. This will disable automatically installed updates. 
 
Note: Normally you would set ProtectYourPC to 1, automatically install updates. But to reduce the 
installation time for this lab we will set the value to 3. 
 

 
 

Step 12 
Before validating the answer file, expand all components in the autounattend file to make sure 
everything is properly added. 
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If anything is missing, go back over the lab and add the missing components or settings. 
 
Click Tools > Validate Answer File. 
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Select the Validation tab in the “Messages” area.  
 

 
 
If you see any error or warning messages, ask your instructor for assistance in correcting them before 
proceeding with the lab. 
 
If there are no error or warning messages click File > Save Answer File. 
 

Step 13 
Copy the autounattend.xml file from C:\Vista_Installation to the root of the floppy disk or USB flash drive. 
 
Insert the floppy disk in the floppy drive or connect the USB flash drive to a USB port. 
 
Insert the Windows Vista media in the appropriate drive.  
 
Restart the computer. 
 

Step 14 
When the Press Any Key to Boot from CD or DVD message appears, press any key on the keyboard.  
 
The installation of Windows Vista will proceed in a completely unattended fashion, then Vista will run a 
performance check, and finally you will be presented with the logon screen. 
 
Note: The system will flash on and off several times, restart several times, and other times only a black or 
blue screen will appear with nothing else shown during the installation. 
 
Logon to the computer using the administrator name and password used in the autounattend file. 
 
What was the name of the file used to automate the installation located on the floppy disk or USB flash 
drive? 
 
 
How do you think automating the installation will help the IT Department if they have to repeat the 
procedure on 100 computers? 


	TextField1: 



