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5.3.3.5 Lab - Monitor and Manage System Resources in Windows 7
Introduction

Print and complete this lab.

In this lab, you will use administrative tools to monitor and manage system resources.

Recommended Equipment

The following equipment is required for this exercise:
« A computer running Windows 7
* Internet access

Step 1
You will explore what happens when a service is stopped then started.

Log on to Windows as an administrator.

Note: Some antivirus or antispyware programs must be uninstalled on the computer for Windows
Defender to work.

To see if Windows Defender is turned off click Start > in Search programs and files type Defender >
select Windows Defender.

If the “This program is turned off” screen appears, click click here to turn it on.

.:'I This program is turned off

If you are using another program that checks for harmful or unwanted
software, use the Action Center to check that program's status.

If you would like to use this program, dick here to turn it am

Close

Windows Defender should start, if not, uninstall any antivirus or antispyware programs and then click
Start > in Search programs and files type Defender > select Windows Defender.

Click Start > Control Panel > Administrative Tools > Computer Management > expand Services and
Applications > select Services.

Close the Administrative Tools window.

Resize and position both windows so they can be seen at the same time.
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Protection against spyware and potentially unwanted software

Updsted definitions enable detections of the latest harmful or unwanted software and prevent it from running on your computer.

Check for updates now

Ge online to view troubleshooting tips

& Computer Management

:.IEIQ

File  Action

e s

View Help

& Computer Management (L
4 [} system Tools
1+ (5 Task Scheduler

Windows Defender
4 [F] Event Viewer
i [ Custom Views || Stop the service

4 (i Windows Logs || Restart the service

(=] Application

] Security Desciption:

] setup Protection against spyware and
{] System potentially unwanted software

] Forwarded Ey
i [ Applications anc|
4 Subscriptions
& i Shared Folders
&+ & Local Users and Grol
1+ (%) Perfarmance
5 Device Manager
4 88 Storage
29 Disk Management
s Services and Applicatior
i, Services

&5 WMI Control

Name

£ Windows Coler Sys...

% Windows Connect ...
\Windows Defender

£% Windows Driver Fo...
£% Windows Error Rep...
% Windows Event Col...

£ Windows Event Log
£ Windows Firewall

£ Windows Font Cac...

£ Windows Image Ac...

% Windows Installer

2% Windows Manage..

£ Windows Media Ce..
% Windows Media Ce...
2% Windows Media PL...
£ Windows Modules ...
£ Windows Presentat...

£ Windows Remote .

Description Status Startup Type

The WesPlu.. Manual

WCNCSVC . Manual

Protection... Started  Automatic (Delayed Start)
Manages us... Started  Automatic

Allows error.. Manual

This service.. Manual

This service.. Stated  Automatic

Windows Fi.. Stated  Automatic

Optimizes p... Manual

Providesim... Stated  Automatic

Adds, modi.. Manual

Providesac.. Stated  Automatic

Windows M. Manual

Starts and s... Manual

Shares Win... Stated  Automatic (Delayed Start)
Enables inst. Manual

Optimizes p... Manual

Windows R... Manual

Actions

Semvices A
Log On A: -
el More... b
Local Service
Local Service Windows ..
Local System More ...
Local System
Local System

Netwerk Service
Local Service
Local Service
Local Service
Local Service
Local System
Local System
Network Service
Netwerk Service
Network Service
Local System

|

Local Service
Network Service

Extended /i Standard //

Can Windows Defender check for updates?

Scroll the “Computer Management” window so you see the “Windows Defender” service.

What is the Status of the service?

Right-click Windows Defender service > select Stop.

File Action View Help

@5

& Computer Management (Local
4} System Tools
» () Task Scheduler
» {3 Event Viewer
1> @& Shared Folders Stop the service
i # Local Users and Groups| | Restart the service
» (%) Performance
=) Device Manager
4 5 storage
{29 Disk Management
4 Ty Services and Applications
2. Services
i WMI Control

‘Windows Defender

Description:

Protection against spyware and
potentially unwanted software

Name

& Windows Error Re...  Allows erro...
% Windows Event C... This service...

% Windows Font Ca... Optimizes ...
£k Windows Image A... Provides

% Windows Installer
% Windows Manage...
& Windows Media C... Windows ...
% Windows Media C... Starts and s...
% Windows Media P... Shares Win...

& Windows Audio E... Manages a...
% Windows Backup
. Windows Biometri... The Windo...
% Windows CardSpa... Securely en...
% Windows Color Sy... The WesPl...
£k Windows Connect... WCNCSVC ...
#1 Windows Defender
% Windows Driver F...

indows Event Log  This service...
% Windows Firewall

Status
Started

Description Startup Type
Automatic

Provides W... Manual
Manual
Manual
Manual

Manual

Protection ... Started

Manages u... Started Start
Stop L
Pause
Started
Resume
Windows Fi... Started
Restart
Started) All Tasks
Adds, modi...
Providesa.. Started Refresh
Properties
Started Help

Automatic (Delayed Start)

logOnAs  *

Local System
Local System
Local System
Local System
Local Service
Local Service

Local System
Local System
Local System
Network Ser...
Local Service
Local Service
Local Service

y | Local Service

Local System
Network Ser...
Network Ser...

(]

Actions

Local System  —

Network Ser... =

< i + | Bxtended [ Standard /

Services
Meore ...
Windows ...

More ...

Stop service Windows Defender on Local Computer
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Note: The reason this service will be stopped is so you can easily see the results. When stopping a
service, to free up system resources the service uses, it is important to understand how the overall
system operation will be affected.

The “Service Control” window opens and closes.

Select the Windows Defender window so it is active.

Scan |

Protection against spyware and potentially unwanted software

A problem caused this program's service to stop. To start the service, click the Start now button or restart your
computer.
Status
Last scan: Not available
Scan schedule: Daily around 2:00 AM (Quick scan)
Real-time protection: Off
Antispyware definitions: Version 1.931238.0 created on 11/4/2010 at 7:14 PM Ll

What must be done so Windows Defender can run?

Start the Windows Defender service, click Start now.

By Home ¥ Scan |+ {3 H Q

Protection against spyware and potentially unwanted software

Updated definitions enable detections of the latest harmful or unwanted software and Check for updates now N

prevent it from running on your computer.

Go online to view troubleshooting tips

Status
Last scan: Mot available
Scan schedule: Daily around 2:00 AM (Quick scan)
Real-time protection: On

Antispyware definitions: Version 1.93.1238.0 created on 11/4/2010 at 7:14 PM |

Can Windows Defender check for updates?

Close the Windows Defender window.

Make sure the Computer Management window is open.
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& Computer Management »

4 (b System Tools ¥
b (D) Task Scheduler
4[] Event Viewer

Level Date and Time
@Im‘ormation 12/24/2010 1:41:47 PM

1 Informati 12/24/2010 1:41:42 PM
~

Source

ion

Service Control Ma...

Service Control Ma...

EventID Task Categ *

7036 Mene
7036 Mone

[ Applications
[} Subscriptions

Log Name: Syste
b 3] Shared Folders Fethilis st
b % Local Users and (| Source: Service Control Manager Logged: 12/24/2010 1:41:42 PM
b @ Performance Event ID: 7036 Task Category: Mone

= Device Manager Level: Information Keywords: Classic
4 (5 Storage User: /A Computer:  Vicki-PC
&= Disk Managemer = | | oocoae s

R F—— v

» [ Custom View| | |« [ ] " \
4 L Windows L?g Event 7036, Service Control Manager »
] Applicatic
& Security |- General | Details
] Setup 7
[£] System The Windows Defender service entered the stopped state. M
=] Forwarde

1

I Hep »

Fuentd &

m

Expand Event Viewer > Windows Logs > select System.

Select the second event in the list.

Look below the General tab then explain what has happened to the Windows Defender service.

Click the up arrow button on the keyboard or select the event above the one you just viewed.

T — ===

File Action View Help

|

& Computer Management 4
4 [} System Tools
b () Task Scheduler

Level Date and Time

12/24/2010 1:41:47 PM

Source

] Information

Service Control Ma...

7036 Mone

EventID Task Categ *

(! [ 3

W e | || @ e 1 e
& [ Custom View| < L | :
« lig Windows Log W\ [T o o026 Service Control Manager x
i Applicatic
f&] Security r General | Details
] Setup -~
(=] System The Windows Defender service entered the running state. ¥
] Forwarde
i L Applications
-4 Subscript
1 Subscrpliang Log Name: System -
> @l Shared Folders
» & Local Usersand (| Source: Service Control Manager Logged: 12/24/2010 1:41:47 PM
b @ Performance Event ID: 7036 Task Category: Mone
& Device Manager Level: Information Keywords: Classic
4 55 Storage User: M/A Computer: Vicki-PC
= Disk Managemer ~ OpCode: Info -

m

Look below the General tab then explain what has happened to the Windows Defender service.

Close all opened windows.

You will explore what happens when a service is stopped then started.

Note: If Network is not shown in the Start menu, complete the following: Right-click Start > Properties >
Start Menu tab. Click Customize, and then scroll down the list to Network. Place a check mark next to

Network, and then click OK > OK.
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Navigate to the “Network and Sharing Center” window by clicking Start > Network > Network and

Sharing Center.

E=E)

",(-\' . . <« All Control Panel Items » Network and Sharing Center - Search Control Panel L '

Control Panel Home ’ . . . -
View your basic network information and set up connections

Change adapter settings mkl' : 4 l& : ) 0 See full map

Change advanced shari
settings ) VICKI-PC Metwork Internet
(This computer)

View your active networks Connect or disconnect

Network Access type: Internet
Weork network Connections: [ Local Area Connection

Change your networking settings

ﬁ- Set up @ new connection or network
-t

Set up a wireless, broadband, dial-up, ad hoc, or VPN connection; or set up a router or access point.

'-5. Connect to a network

Connect or reconnect to a wireless, wired, dial-up, er VPN network connection.

ﬂ Choose homegroup and sharing options
See also Access files and printers located on other network computers, or change sharing settings.

HemeGroup

K Ol Troubleshoot problems

§ X Diagnose and repair network problems, or get troubleshooting infermation.
Windows Firewall

Click Change adapter settings in the left pane.

Reduce the size of the “Network Connections” window. Leave this window open.

o= |
. @ <« Metw... » Metwork Connections » - :. Search Network Connections 2 |

Organize =

H Local Area Connection
g Metwork

@ Marvell Yukon 88E3001/8003/801..

Navigate to the “Control Panel” window by clicking Start > Control Panel.
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s ij‘ » Control Panel » All Control Panel ltems »
p—

+3 [l Search Control Pane!

[ e

Display

<& Keyboard

F Action Center
By Backup and Restore
@ Default Programs

. l Getting Started

Notification Area Icons
o

Adjust your computer’s settings

HomeGroup

Sensors

{~?1 Administrative Tools
¥
| Colar Management

Desktop Gadgets

Location and Other

Parental Controls

Ease of Access Center

E =y

’

Q¥

Mouse

Credential Manager
Device Manager
Folder Options

Indexing Options

Audio Control Panel

Performance Information
and Tools

Viewby: Large icons =

@ AutoPlay

Date and Time

ﬂiﬁ Devices and Printers

h Fonts
-

Internet Options

.I:I- Network and Sharing
Center

q‘ Personalization

] »

mn

Click the Administrative Tools icon.

The “Administrative Tools” window opens.

@5

» Control Panel » All Control Panel ltems » Administrative Tools

Shortcut

== Removable Disk) _

Performance Monitor Date modified: 7/13/2003 9:41 PM

Size: 1.20 KB

Date created: 7/13/2009 9:41 PM

Organize ¥ [ Open  Bum

I Favortes * Name . Date modified Type Size
I Desktop [#+ Compenent Services 7/13/2009 946 PM  Shortcut 2KB
18 Downloads (2 Computer Management 7/13/2009 341 PM  Shortcut 2KB
" Recent Places Data Sources (ODBC) 7/13/2009 941 PM  Shortcut 2KB
[#] Event Viewer 7/13/20099:42PM  Shortcut 2KB
i Libraries [ek, iSCST Initiator 7/13/2009 341 PM  Shortcut 2KB
[ [ Documents  |£ [k Local Security Policy 11/6/20105:39 AM  Shortcut 2KB
&' Music |{#) Performance Moniter K 7/13/2000 941 PM  Shortcut 2KB
] Pictures [#8 Print Management 11/6/2010533 AM  Shortcut 2KB
| B videos [#): Services 7/13/2009 941 PM  Shortcut 2K8
@I System Configuration 7/13/2009 9:41 PM Shortcut 2KB
+& Homegroup (2 Task Scheduler 7/13/20099:42PM  Shortcut 2KB
[P Windows Firewall with Advanced Security  7/13/2000 841 P Shortcut 2KB
% Computer Windows Memory Diagnostic 7/13/2009 941 PM  Shortcut 2KB
1 & Local Disk(C) (& Windows PewerShell Modules 7/13/20099:52PM  Shortcut 3KB

Double-click the Performance Monitor icon.

The “Performance Monitor” window appears. Make sure the Performance Monitor in the left pane is

highlighted.
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= | E [t |

BOE

(%) Performance
4 [ Monitoring Tools
Performance Monitor |

Ere- X2 .05 M B

I Freeze Display (Ctrl+F) b

1+ [ 54 Data Collector Sets
1> [ Reports

100

90|

804

704

60

50+

40

304

204

104

Q
4:44:26 PM

4:44:41 PM 4:44:51 PM 4:45:00 PM - 4:45:10 PM 4:45:20 PM 4:45:30 PM 4:45:40 PM - 4:45:50 PM

4:46:04 PM

Last |

1563 Average|

5993 Minimum |

0.000 Maximum |

33504 Duration |

1:40

Show

™

Color

Scale

Counter

Instance

Parent Object

Computer

Click the Freeze Display icon to stop the recording.

Right-click the Performance Monitor menu bar and select Clear to clear the graph. Leave this window

open.
- FSE)
=l
®Vfw’;erform.anc.e ?E"#xg‘ﬁaﬂ““'” |
4 | g Monitoring Tools Add Counters... I
- B8 Performance Monitor s Save Settings As.. (|
I L7 Data Collector Sets - -
= ave Image As...
1 [ Reports
Save Data As...
804 Clear
Zoom To
Show Selected Counters
60 Hide Selected Counters
Scale Selected Counters
Remove All Counters
409 Properties...
204

0
44844 PM  448:54 PM 4:49:04 PM 44214 PM 4:49:24 PM 4:49:34 PM 4:49:44 PM 4:49:54 PM - 4:50:04 PM 4.

4:50:22 PM

Last |

4688 Average |

4688 Minimum |

4688 Maximum |

4588 Duration |

1:40

Show

Color

Scale

Counter

Instance

Parent Object

Computer

¥ ———10  %PocesorTime  Toal -~ Pocesorlformation  \WICKLRC

Navigate to the “Administrative Tools” window by clicking Start > Control Panel > Administrative Tools.
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VA —
() » Control Panel » All Control Panel ltems » Administrative Tools ~ [ 4 ||| Search Administrative Tools »
Organize »  [17] Open Burn - [l @
e - Name : Date modified Type Size
M Desktop 3+ Component Services 7/13/20099:46 PM  Shortcut 2KB
18 Downloads (& Computer Management 7/13/20099:41 PM  Shortcut 2B
] Recent Places Data Sources (ODBC) 7/13/20099:41 PM  Shortcut 2KB
{5 Event Viewer 7/13/20099:42PM  Shortcut 2KB
4 Libraries &l iSCSH Initiator 7/13/20099:41 PM  Shortcut 2KB
|3 Documents  |=| @ Local Security Policy 11/6/2010 539 AM  Shortcut 2kB
& Music (&) Performance Monitor 7/13/20099:41 PM  Shorteut 2KB
=] Pictures & Print Management 11/6/2010 533 AM  Shortcut 2KB
B videos | Services 7/13/20099:41 PM_ Shortcut 2kB|
B System Configuration 7/13/20099:41 PM  Shortcut 2KB
+& Homegroup (&) Task Scheduler 7/13/2009942PM  Shortcut 2B
|| @ Windows Firewall with Advanced Security  7/13/20099:41 PM  Shorteut 2kB
1% Computer Windows Memory Diagnostic 7/13/20099:41 PM  Shortcut 2KB
&, Local Disk (C) &8} Windows Powershell Modules 7/13/20099:52PM  Shortcut 3KB
e Removable Disk | _
| 7\ Services Dete modified: 7/13/2009 341 PM Date created: 7/13/2009 9:41 PM
| "»ad_":‘-_ Shortcut Size: 1.25 KB
| =

Double-click the Services icon.

Expand the width of the “Services” window so you have a clear view of the content. Scroll down in the
right pane until you see the service Routing and Remote Access.

File Action View Help
e |EEc=z HEl v unmn

& Services (Local) | | NS gervices (Local)

Routing and Remote Access Name Description Status Startup Type Log On As =
X £ Power Manages power polic...  Started Automatic Local Syste...
De Chtite £ Print Spooler Loads files to memory... Started Automatic Local Syste...

Offers routing services to businesses

in local area and wide area network & Problem Reports and Seluti...  This service provides s... Manual Local Syste...
environments, & Program Compatibility Assi... This service provides s..  Started Manual Local Syste...
4 Protected Storage Provides protected st..  Started Manual Local Syste...
54 Quality Windows Audio Vid... Quality Windows Aud... Manual Local Service
% Remote Access Auto Conne... Creates a connection ... Manual Local Syste...
% Remote Access Connection... Manages dial-up and ... Manual Local Syste...
; Remote Desktop Configurat... Remote Desktop Conf... Manual Local Syste...
i Remote Desktop Services Allows users to conne... Manual Network 5... P
& Remote Desktop Services U...  Allows the redirection... Manual Local Syste...
%, Remote Procedure Call (RPC) The RPCSS serviceist.. Started Automatic Network S... E
& Remote Procedure Call (RP... In Windows 2003 and ... Manual MNetwork S... L4
%, Remote Registry Enables remote users Manual Local Service

ng and Remote Access

4 RPC Endpoint Mapper

Resolves RPC interfac. Started Automatic

£ Secondary Logon Enables starting proce... Manual Local Syste...
£ Secure Socket Tunneling Pr...  Provides support fort... Manual Local Service
& Security Accounts Manager  The startup of this ser..  Started Automatic Local Syste...
& Security Center The WSCSVC (Windo...  Started Automatic (D.. Local Service
G4, Server Supports file, print, an... Started Automatic Local Syste... v,

Extended /| Standard /

Double-click Routing and Remote Access.

The “Routing and Remote Access Properties (Local Computer)” windows opens.
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- 5
Routing and Remote Access Properties (Local Computer) ﬁ

General | Log On | Recovery | Dependencies |

Service name: Remotefcoess

Display name: Routing and Remote Access

[Offers routing services to businesses in local area -

Description:
and wide area network environments.

Fath to executable:
C\Windows'System 32 svchost exe 4 netsves

Startup type: Manual -

Help me corfigure service startup options.

Service status:  Stopped
Stop Pause Resume

Start

You can specify the start parameters that apply when you start the service
from here.

| ok || cance || Fq::phf%J‘

L™ - 4

In the Startup type select Manual. Click Apply.

The Start button is now active; do not click the button yet. Leave this window open.

Position the following three windows so you can clearly see them at the same time: Network Connections,
Routing and Remote Access Properties (Local Computer), and Performance Monitor.

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 9 of 33



IT Essentials

Chapter 5 Lab

&/ « Netw... » Network Connections »

Organize =

"~ Local Area Connection
Network

WP Marvell Yukon B3EB001/8003/801....

17 Perfnrmance Mositor

[ Fle  Action  View

8 Peemance
« @ Montenng Teels

Window  Help

| 2@ Cw @

. Beports

i
fi

CEEEEET IR ELICCIL]
. 5 Data Cobector Sets.
L
0
4D
]
ESTO4PM ESTASPM SS54SPM 5555 PM SSG0S PM ASEASPA 4SEZIPM 45635 PM 585 PM 4. ESI0EPM
tmt| Aweage | s Minemum | e Maimum| e Ourstn 14
Show Celor Scale Courter Imtance Parert Object Compter
o

-
Routing and Remote Access Properties (Local Computer)

General |LogDn | Recovery I Dependancies|
Service name: RemotefAccess
Display name: Routing and Remote Access
Description: ers routing services to businesses in local area »
nd wide area network environments. = N
i
Path to executable:
C:\Windows'\System32svchost exe & netsves
Startup type: [ Manual hd
Help me configure service startup options.
Service status:  Stopped
¥
! Start | | Stop | | Pause . | Resume |
You can specify the start parameters that apply when you start the service
from here.
¥
Start parameters: |

[ ok ][ canca || nppoybj

=)
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Click the “Performance Monitor” window so it is activated.

() File Action View Window Help
= |5EE =]

(%) Performance

Sl B Hre-+X2lza@a@p B

S e ——

[-[=]x]

B8 Performance Monitor Unfreeze Display (Ctrl+F) |
1 [54 Data Collector Sets e
» [ Reports
80+
604
40+
201
50320 PM  503:30 PM 5:03:40 PM 50350 PM 50400 PM 50410 PM 50420 PM 50430 PM  5:04:40 PM  5:04:50 PM 5:04:59 PM

La;t‘ --------- Average‘

Minimum|

Max\mum‘ --------- Duration | 140
Show Color Scale Counter

Instance Parent Object

Computer
¥ ———10  %ProcessorTime  Totl - Processorlnformaion  \WIICKLPC

Click the Unfreeze Display icon to start the recording.

Click the “Routing and Remote Access Properties (Local Computer)” window so it is activated. To start
the Service click Start.

A window with a progress bar opens.

-

Service Control

- el Sl —

Windows is attempting to start the following service on Local Computer...
Routing and Remote Access

Close

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.
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The “Routing and Remote Access Properties (Local Computer)” window now shows the Stop and Pause

button active. Leave this window open.

Routing and Remote Access Properties (Local Computer) u

General | Log On I Recovery | Dependemciesl

Service name: Remotefocess

Digplay name: Routing and Remote Access

ers routing services to businesses in local area -

nd wide area network environments.
1

Description:

Path to executable:
I CWindows" System 32 svchost exe 4 netsves

Startup type: Manual -

Help me configure service startup options.

Service status:  Started

Start [ Stop ] [ Pause ] Resume

You can specify the start parameters that apphy when you star the service
fram here.

Start parameters:

Click the “Network Connections” window so it is activated.

'J_'(:\ "‘ @ < Metw... » Metwork Connections » - __ Search Network Connections

Organize *

Local Area C cti 1 5 :
] et el | Incoming Connections
S MNetwork | ;
r; : Mo clients connected

GET Marvell Yukon 88E8001/8003/801..

Press function key F5 to refresh the content.

What changes appear in the right pane, after starting the Routing and Remote Access service?

Click the “Routing and Remote Access Properties (Local Computer)” window so it is activated.

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.
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- :
Routing and Remote Access Properties (Local Computer) u

General | Log On I Recovery I Dependaﬂcies|

Service name: RemoteAccess

Display name: Routing and Remote Access

Description: ers routing services to businesses in local area -
nd wide area networlc environmerts .

Path to executable:
I CAWindows'System 32 gvchost .exe 40 netaves

Startup type: [Manual w

Help me configure service startup options.

Service status:  Started

Start [ Stop {}J [ Fauze ] | Resume

You can specify the start parameters that apply when you start the service
from here.

Start parameters:

Click Stop.
Click the “Network Connections” window so it is activated.
=Ta x

.?. '_. | @ « Metw... » MNetwork Connections » - | Search Network Connections e

Organize =

."-. Local Area Connection
= Network

W Marvell Yukon 88E8001/8003/801..

What changes appear in the right pane, after stopping the Routing and Remote Access service?

Click the “Performance Monitor” window so it is activated.
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(%) File Action View Window Help
L e AN

(%) Performance

D | H R

[ [=][=]

PE- By E Ij»l | B
4 [ Monitoring Tools = ‘ X7 ‘ = o “!E\\;’” 2

- B8 Performance Monitor i | Freeze Display (Ctrl=P) k-

i+ L2 Data Collector Sets
3 _ﬁ Reports

80+

60

40+

i /\

0 f/\,/\/\_

Last | 1563 Average | 4204 Minimum |

517:36 PM  5:17:46 PM  5:17:56 PM  5:18:06 PM  5:18:16 PM  5:18:26 PM  5:18:36 PM  5:18:46 PM  5:18:56 PM  5:19:06 PM 5:19:15 PM

Show Color Scale Counter

0000 Maximum | 17969 Duration |

1:40

Instance
o

Parent Object

Camputer

Click the Freeze Display icon to stop the recording.

[ performance Moritor ===

Which Counter is being recorded the most in the graph (hint: look at the graph color and Counter color)?

Click the Change graph type drop-down menu, select Report.

[ performance Moritor e

() File Action View Window Help

e =|
O e EBref+Xs 05/ P M
4 | gw Monitoring Tools
BE Performance Monitor Y Line
1 [ Data Collector Sets e Histogram bar
i+ L] Reports Report N
80+
60
40+

0
519:55 PM  5:20:05 PM  5:20:15PM  5:20:25 PM 5:20:35PM  5:20:45PM  5:20:55 PM 5:21:05 PM 5:21:15 PM 5:21:25 PM 5:21:34 PM

Last | 1563 Average | 5510 Minimum | 1.563 Maximum | 24219 Duration | 1:40
Show Color Scale Counter Instance Parent Object Computer
[

The display changes to report view.
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e | fEE=HE
& Performance Era-+X7 =0Ea b @

4 i Monitoring Tools
B Performance Monitor
[ _\3 Data Collector Sets

WVICKI-PC
o Processor Information _Total
b L Reports % Processor Time 1.563

List the values of the counter.

Click the “Routing and Remote Access Properties (Local Computer)” window so it is activated.

i — B
Routing and Remote Access Properties (Local Computer) . | -\u;

General | Log On I Recovery | Depemdmdes|

Service name: Remotefocess

Dizplay name: Fouting and Remate Access

ers routing services to businesses in local area ~

Description:
pt nd wide area network environments.

Path to executable:
C:Windows" System 32 esvchost exe 4 netsves

Startup type: [[]isabled b

Help me configure service startup options.

Service status:  Stopped
Start | Stop Pause | Resume

You can specify the start parameters that apphy when you start the service
fram here.

Start parameters:

| oK D}J[ Cancel

In the Startup type select Disabled. Click OK.

Click the “Services” window so it is activated.
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2 Services

File Action View Help

e=»|EEa=H

£ Services (Local) }%

Routing and Remote Access Name ° Description
£ Remote Access Connection... Manages dial-up and ...
Description:
Offers routing services to businesses
in local area and wide area network
environments, i Remote Desktop Services U...  Allows the redirection...
. Remote Procedure Call (RPC) The RPCSS service s L.
. Remote Procedure Call (RP... In Windows 2003 and ...

£ Remote Desktop Configurat... Remote Desktop Conf...
i Remote Desktop Services Allows users to conne...

. Remote Registry Enables remote users ...
Q Routing and Remote Access  Offers routing service...
£ RPC Endpoint Mapper Resolves RPC interfac...

% Secondary Logon Enables starting proce...
4 Secure Sacket Tunneling Pr...  Provides support for t..
. Security Accounts Manager  The startup of this ser...
(. Security Center The WSCSVC (Windo...

£k Server Supsorts file orint. an...

Status
Started

Started

Started

Started
Started
Started
Started

Startup Type
Manual
Manual
Manual
Manual
Automatic
Manual
Manual
Disabled
Automatic
Manual
Manual
Automatic
Automatic (D...

Automatic

Log On As

Local Syste...
Local Syste...
Network 5...
Local Syste...
Network 5.,
Metwork 5...

Local Service

Local Syste...
Network 5...
Local Syste...

Local Service
Local Syste...
Local Service
Local Svste...

|

Bxtended /{ Standard /

What is the Status and Startup Type for Routing and Remote Access?

Click the “Performance Monitor” window so it is activated.

(%) File Action View Window Help
G| = | H

2 reromance worv - - =
=le]x)

Click the Unfreeze Display icon to start the recording.

Close all open windows.

Dsennirss Ere- X700 E
4 | gg Menitoring Tools 14
BE Performance Moniter o .[ Unfreeze Display (Ctrl+F) Lv
I ___3 Data Collector Sets
i+ [ Reports
50
o J\/\_,WJ\ . .
| 5:19:55 PM 5:20:25 PM 5:20:55 PM 5:21:34 PM
[l Last | 1.562 Average | 5510  Minimum 1.563
Maximum 24,219  Duration 1:40
i
I Show Color Scale Counter Instance Parent
N —

Navigate to the “Administrative Tools” window by clicking Start > Control Panel > Administrative Tools.
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’ ‘ | + Control Panel » All Control Panelltems » Administrative Tools - | Search Administrative Te
Organize » [ Open Burn & - O @
7 (] 1 = >~ - : o

[ Favorites P | E | 1 ) ;'\‘)1 F 47 o ’{ f‘:*]‘

e “i] s %]

Bl Desktop |ﬁ y “p , @ﬂ:{' -p!

& Downloads Componen | Computer Data Event iSCSI Local Performanc Print Services System
%= Recent Places tServices | Manageme Sources Wiewer Initiator Security eMonitor  Manageme Configurati

nt L\‘ (ODBC) Policy nt on

s B A B

‘Jj Music Task Windows Windows Windows

Scheduler Firewall Memory PowerShell
Pictures with Diagnostic Modules
H videos Advanced...

& Homegroup

. Computer
&, Local Disk (C:)
== Removable Disk (E:)

e‘j Network
| Computer Management Date modified: 7/13/2009 9:41 PM Date created: 7/13/2009 9:41 PM
Shortcut Size: 1.26 KB

Double-click the Computer Management icon.

The “Computer Management” window appears. Expand the three categories by clicking on the arrow
next to: System Tools, Storage, and Services and Applications.

File Action View Help
= H

& Computer Management (Local)| || Name Actions
a '[f& System Tools

[ @ Task Scheduler @

i 2] Event Viewer ﬂﬂStorage Maore Actions »

T Services and Applications

'ﬁ’é System Tools Computer Management (L., &

I+ &l Shared Folders
I ;-k,- Local Users and Groups
> (%) Performance
=4 Device Manager
a 25 Storage
&=¢ Disk Management

a ::4"3 Services and Applications

G Services

&5 WMI Control

Click the arrow next to Event Viewer then click the arrow next to Windows Logs.
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File Action

|

View Help

;g'\ Computer Management (Local)
4 |f} System Tools
b (5 Task Scheduler
[l Event Viewer
1 [ Custom Views
4 [ Windows Logs
[ Application
[+ Security

E] setup
s v

=]
] Forwar
1+ [ Applications and Services Logs
[ 74 Subscriptions
b @t Shared Folders
& &8 Local Users and Groups
b (%) Performance
5 Device Manager
3 Storage
(=7 Disk Management
Z Services and Applications
% Services

&5 WMI Control

S

[N

Level Date and Time Source EventID TaskC... b
®Information 11/7/2010 5:30:52 PM Service Control Manager 7036 MNone £
@Informatiun 11/7/2010 5:24:01 PM Service Control Manager 7040 MNone
(Dlnfnrmatiun 11/7/2010 5:20:10 PM Service Control Manager 7036 MNene
(Dlnformation 11/7/2010 5:20:00 PM Service Contrel Manager 7036 MNene
®InfDrmation 11/7/2010 5:17:52 PM Service Control Manager 7036 MNene
®Infnrmatmn 11/7/2010 5:17:41 PM Service Contrel Manager 7036 Nene
®Informatlon 11/7/2010 5:17:13 PM Service Control Manager 7036 None
®Infnrmatlon 11/7/2010 5:17:02 PM Service Control Manager 7036 None
(DInfarmation 1172010 5:16:20 PM ervice Control Manaoer 1036 None =
Event 7036, Service Control Manager x

[The Application Experience service entered the running state.

Log Name: System

Source: Service Control Manager  Logged: 11/7/2010 5:30:52 PM

Event ID: 7036 Tack Category: None

Level: Information Keywords: Classic

User: N/A Computer: Vicki-PC

OpCode: Info

More Information:  Event Leg Online Help

System -
= OpenSaved Log...
¥ Create Custom View...
Import Custom View...
Clear Log...
¥ Filter Current Leg...
(5] Properties
E Find..
Jed Save All Events As...
Attach 2 Task To this L.,
View >
[c Refresh
H Hep »
Event 7036, Service Control ... =
[=] Event Properties
] Attach Task To This Ev...
Copy >
fed Save Selected Events...
G Refresh

H rep »

Select System.

Double-click the first event in the window.

File Action

|2

View Help

& Computer Management (Local)
4 [f} System Tools
& (D Task Scheduler
4 [3] Event Viewer
1> [F Custom Views
4 [ Windows Logs
[ Application
& Security
] Setup
& System
] Forwarded Events
b [ Applications and Services Logs
Subscriptions
b ] Shared Folders
b & Local Users and Groups
1+ (%) Performance
5 Device Manager
5 storage
{27 Disk Management
= Services and Applications

S

S

4% Services

&5 WMI Control

Level Date and Time Source EventID Task C... b
Control Manager [

(D) Information Service Control Manager 7040 None
®Infnrmatmn 11/7/2010 5:20:10 PM Service Control Manager 7036 Nene
@Informatlon 11/7/2010 5:20:00 PM Service Control Manager 7036 None
@Infnrmatlon 11/7/2010 5:17:52 PM Service Control Manager 7036 None
®Informatlon 11/7/2010 5:17:41 PM Service Control Manager 7036 None
®Informatlon 11/7/2010 5:17:13 PM Service Control Manager 7036 None
@Infnrmation 11/7/2010 5:17:02 PM Service Control Manager 7036 MNone
(nformation 1172010 5:16:20 PM envice Control Manaoer 7036 None ¥
Event 7036, Service Control Manager x

[The Application Experience service entered the running state.

Log Name: System

Source: Service Control Manager Logged: 11/7/2010 5:20:52 PM

Event ID: 7036 Task Category: None

Level: Information Keywords: Classic

User: N/A Computer: Vicki-PC

OpCode: Info

More Information:  Event Log Online Help

= OpenSaved Log...

¥ Create Custom View...
Import Custom View...
Clear Log...

T Filter Current Log...

(] Properties

88 Find..
fed Save All Events As...
Attach a Task To this L.,

View »
|G Refresh
H Hep »

Event 7036, Service Control ... &
[E] Event Properties

E] Attach Task To This Ev...
&g Copy 4
jed Save Selected Events...

[cl Refresh

[ Hep »

The “Event Properties” window opens for the event.

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.

Page 18 of 33



IT Essentials

Chapter 5 Lab

4| Event Properties - Event 7040, Service Contral Manager

General | Details

disabled.

Log Mame:
Source:
Event ID:
Level:
User:
OpCode:

More Information:

Systermn

Service Control Manager
7040

Information
Vicki-PC\Wicki

Info

Event Log Online Help

The start type of the Routing and Remote Access service was changed from demand start to

Logged: 11/7/2010 5:24:01 PM
Task Category: MNone

Keywords: Classic

Computer: Vicki-PC

(¢ (o]

Close

Click the down arrow key to locate an event for Routing and Remote Access.

You should find four events that describe the order for starting and stopping the Routing and Remote

Access service.

Write down the description for each of the four events.

2] Event Properties - Event 7040, Service Cantrol Manager

General | Details

start.

Log Name:
Source:
Event ID:
Level:
User:
OpCode:

Mere Information:

System

Service Control Manager
7040

Information
Vicki-PC\Vicki

Info

Event Log Online Help

The start type of the Routing and Remote Access service was changed from disabled to demand

Logged: 11/7/2010 4:54:44 PM
Task Category: Mone

Keywords: Classic

Computer: Vicki-PC

[« &

Close
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-
@ Event Properties - Event 7036, Service Control Manager

General | Details

Log Mame:
Source:
Event ID:
Lewvel:
User:
OpCode:

Mare Information:

Systemn

Service Contrel Manager
7036

Information

MN/A

Info

Event Log Online Help

The Routing and Remote Access service entered the running state.

Logged: 11/7/2010 5:05:37 PM
Task Category: Mone

Keywords: Classic

Computer: Vicki-PC

[«) (%]

Close

-
12| Event Properties - Event 7036, Service Contral Manager

General | Details

Log Mame:
Source:
Event ID:
Level:
User:
OpCode:

Maore Information:

System

Service Control Manager
1036

Information

MN/A

Info

Event Log Online Help

The Routing and Remote Access service entered the stopped state.

Logged: 11/7/2010 5:05:52 PM
Task Category: Mone

Keywords: Classic

Computer: Vicki-PC

[«) (%]

Close
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Q Event Properties - Event 7040, Service Control Manager

General | Details

disabled.

Log Mame:
Source:
Event ID:
Lewvel:
User:
OpCode:

More Information:

System

Service Control Manager
7040

Information
Vicki-PC\Wicki

Info

Event Log Online Help

The start type of the Routing and Remote Access service was changed from demand start to

Logged: 11/7/2010 5:24:01 PM
Task Category: Mone

Keywords: Classic

Computer Vicki-PC

Close

Close all open windows.

Step 3

For the rest of this lab, you will configure advanced Administrative Tool features and monitor how this
affects the computer system.

Click Start > Control Panel > Administrative Tools > Performance Monitor.

The “Performance Monitor” window opens.
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@File Action View Window Help

7]
@ Performance | -
1B Mc;l-'i-\t;ring Tools | Overview of Performance Monitor ]
- B8 Performance Monitor ) You can use Performance Monitor to view perfermance data either in real time or from a log file. Create Data
i L3 Data Collector Sets k Collector Sets to configure and schedule performance counter, event trace, and configuration data collection
3 n Reports so that you can analyze the results and view reports,
To begin, expand Monitoring Tools and click Performance Monitor, or expand Data Collector Sets or Reports.
The new Resource Monitor lets you view detailed real-time information abeut hardware resources (CPU, disk,
netwaork, and memary) and system resources (including handles and modules) in use by the operating system,
services, and running applications. In addition, you can use Resource Monitor to stop processes, start and stop
services, analyze process deadlocks, view thread wait chains, and identify processes locking files. =
Open Resource Monitor
System Summary
-
NVICKI-PC |
Memory =
% Committed Bytes In Use 13985
Available MBytes 2,317.000
Cache Faults/sec 0.000 E_
MNetwork Interf; isatap.{F1E062E3-39EC-4ESA-B53B-D8BBBE23DB0B}  isatap.(F95ADE84-8F8F-41 _
L™ o 3
Learn Mare =]
Done
=3 —— J

Expand Data Collector Sets > right-click User Defined > New > Data Collector Set.

@File Action View Window Help

7]
@ Performance -
4 [ Menitoring Tools | Overview of Performance Manitor ¥
- B8 Performance Manitor \7 You can use Performance Monitor to view performance data either in real time or from a log file. Create Data
4l D?t_a Collector Sets k Collector Sets to configure and schedule performance counter, event trace, and cenfiguration data collection
b | S User Defined | so that you can analyze the results and view reports.
> Lm System Mew ] Data Collector Set ’ :
Ewnk i click Performance Moniter, or expand Data Collector Sets or Reports,
7 Startu Mew Window from Here
Lo P ew Resource Monitor lets you view detailed real-time information about hardware resources (CPU, disk,
1 L Reports Behech rk, and memery) and system resources (including handles and modules) in use by the operating system,
<, and running applications. In addition, you can use Resource Monitor to stop processes, start and stop
Help s, analyze process deadlocks, view thread wait chains, and identify processes locking files. =
Open Resource Monitor
System Summary
-
WAVICKI-PC E|
Memory =
% Committed Bytes In Use 14.258
Available MBytes 2,301.000
Cache Faults/sec 0.000 L
Network Interface isatap.{FLE062E3-39EC-4ESA-B53B6-D8BBBE23DB0B}  isatap.{F95ADE84-8F8F-41
Ch™ | T o 3
Learn Mare =
Create a new Data Collector Set.
=3 ——

The “Create new Data Collector Set” window opens.
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I\../’I [:i‘_i_ii' Create new Data Collector Set.

How would you like to create this new data collector set?

Mame:

Memaory Logs|

(") Create from a template (Recommended]
How do I work with templates?

@) Create manually (Advanced)
How do I choose data collectors manually?

Finish

Cancel

In the Name field, type Memory Logs. Select the Create manually (Advanced) radio button > Next.

The “What type of data do you want to include?” screen appears.

-

@ @:ji' Create new Data Collector Set.

|

What type of data do you want to include?

@ Create data logs
Performance counter
|:| Event trace data

|:| System configuration information

I Performance Counter Alert

[ NextL\Js[ Finish | | Cancel

L%

Select Performance counter > Next.

The “Which performance counters would you like to log?” screen appears.
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@ @ Create new Data Collector Set.

e — S

Which performance counters would you like to log?

Performance counters:

Sample interval: Units:

E 3

Add...

Remove

[ Next || Finish || Cancel

L

Click Add.

From the list of available counters locate and expand Memory.

¥ -—ﬁi

-

L

Available counters

Select counters from computer:

¥ Browse...

-

<Local computer >

Memory -
% Committed Bytes In Use
Available Bytes
Available KBytes |j
Cache Bytes
Cache Bytes Peak
Cache Faults/sec
Commit Limit

Instances of selecked object:

Search

[~ Show description

Added counters

Counter

Parent Inst...

Computer

Remove <<

Help

OK

1 [ Cancel

J

Select Available MBytes > Add.
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r ———ﬁi

Available counters
Select counters from computer:
<Local computer >

-
Memory A LA
%% Committed Bytes In Use
Available Bytes -
Available KBytes |
Available MBytes
Cache Bytes
Cache Bytes Peak
Cache Faults/sec
Commit Limit

Instances of selected object:

Search

[ show description

Added counters

Counter Parent Inst... Computer
Memory ~
Available MBytes — —

Remove <<

Help ] [ 0K %J [ Cancel

Click OK.

Set the Sample interval field to 4 seconds.

-

@ @ Create new Data Collector Set.

Performance counters:

Which performance counters would you like to log?

‘\Wemony\Available MEBytes

Add...

Remove

Sample interval: Units:

a +| |seconds

[ Nextkj[ Finish | | Cancel

Click Next.
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-~ R
— X
@ @' Create new Data Collector Set. - G- i
Where would you like the data to be saved?
Root directory:
Browse...[
[ Nex || Finish || Cancel

h oy
Click Browse.

The “Browse For Folder” window opens.

o ™
Browse For Folder ﬁ

Select a root path for the collected data.

»

Ll Computer
> == Floppy Disk Drive (4:)
| | 4&, Local Disk (C))

] > W inetpub |
40 Pe;flLog;.
4. Admin |
I 4 Program Files [
0 Users
> Windows

. Windows_T_Installation
> i DVD RW Drive (D)
I =g Local Disk (E:)

> New Volume ()

Make Mew Folder ’ Ok !}J [ Cancel

L A

Select drive (C:) > PerfLogs > OK.
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The “Where would you like the data to be saved?” window appears.

@ [;'?‘_ﬁ:' Create new Data Collector Set. - R—— -

Where would you like the data to be saved?

Root directory:

| Nedt %][ Finish | | Cancel

Click Next.
The “Create the data collector set?” screen appears.

@ [f_i_‘:i' Create new Data Collector Set. = R—— -

Create the data collector set?

Run as:

() Open properties for this data collector set
() start this data collector set now

@ Save and dose

Net | | Finish!}][ Cancel

e

Click Finish.
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Expand User Defined > select Memory Logs > right-click Data CollectorOl1 > Properties.

(%) File Action View Window Help
e« | 2FXRE = HF

@ Performance

- Type
a [ Monitoring Tools
B8 Performance Monitor
a __:1| Data Collector Sets
4 :3 User Defined
7 Memory Logs
> [ System

Perfarmance Counter

| s Event Trace Sessions

:-\,i, Startup Event Trace Sessions
i [ Reports

4

Output

1

Opens the properties dialog box for the current selection.

The “DataCollector01 Properties” window opens.

Performance Counters |Fi|E |

Performance counters:

WMemory\Available MBytes

Rem

Add...
| Remove |

Log format:

Tab Separated h‘ Unitz:
s0L

[] Maximum samples:

Binary Seconds ¥ 0

Data source name:

[ O ][ Cancel ] -Api:.l'-rj

|

Change the Log format: field to Comma Separated.
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Click the File tab.

DataCollector(1 Properti

| Performance Counters | File |

Log file name:

DataCollector0l

File name format:

[] Prefix file with computer name

Log mode
|:| Owverwrite
Append

Circular (requires a non-zero maximum file size)

Example file name:
}:::\Perﬂ_ogs‘l,h'ICIC[—PC_ZDmqu—UUUUU 1'\DataCollector0l.cav

[ K %J[ Cancel H Apply H Help

L &

What is the full path name to the example file name?

Click OK.

Select the Memory Logs icon in the left pane of the “Performance Monitor” window.
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View Window Help

e rEXDc=Ba/(NEAE
@ Performance
a [ Monitoring Tools

B8 Performance Monitor
a _\‘1; Data Collector Sets

4 [ Us:

> [ System

[ [=]x]

MName [ Start the Data Collector Set. l’ype
[ DataCollectordl

Output

Performance Counter

ined

emory Logs |

_:-\,L Event Trace Sessions
: L Startup Event Trace Sessions
i [ Reports

Click the green arrow icon to start the data collection set.

Notice a green arrow is placed on top of the Memory Logs icon.

() File Action

e EXEc=BHE puHE

@ Performance
a [ Monitoring Tools
B8 Performance Monitor
a _\j; Data Collector Sets
4 1‘, User Defined
|5 Memory Logs|

b [ Sy
_:-\,L Event Trace Sessions
[ Startup Event Trace Sessions

i [ Reports

Mame
[] DataCollectoril

Type
Performance Counter

Output
CA\Perflogs\VICKI-PC_20101224-0000014C

I

To force the computer to use some of the available memory, open and close a browser.
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View Window Help

e 7EAIXD o= Em rmHd

@ Performance
4 [ Monitoring Tools

B8 Performance Monitor
4 _\j; Data Collector Sets

[ Event Trace Sessions
L Startup Event Trace Sessions

-

i [ Reports

MName [ Stop the Data Collector Set. k

DataCollector0l

Performance Counter

Output
C\Perflogs\VICKI-PC_20101224-000001°\C

1

Click the black box icon to stop the data collection set.

What change do you notice for the Memory Logs icon?

(&) File Action

5| rEIXE = B/ P a2 EdE

View Window Help

@ Performance
4 [ Monitoring Toals
B8 Performance Monitor
4 [} Data Collector Sets
4 1‘, User Defined

_:-\,L Event Trace Sessions
: _:-\,L Startup Event Trace Sessions
i [ Reports

MName

DataCollectar01

Type
Performance Counter

Cutput
C\Perflogs\VICKI-PC_20101224-000001°\L

n

Click Start > Computer > double-click drive C: > PerfLogs > Continue > VICKI-PC_20101224-00001 >

Continue.
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G-

v Computer » Local Dlsk(C:) » Perflogs » VICKI-PC_20101224-000001

Organize *

- Favorites
Bl Desktop
4 Downloads

':.'_- Recent Places

File Edit View Tools Help

|| DataCollector0l.csv,

Include in li