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5.3.3.6 Lab - Monitor and Manage System Resources in Windows Vista

Introduction

Print and complete this lab

In this lab, you will use administrative tools to monitor and manage system resources.

Recommended Equipment

The following equipment is
» A computer runni
* Internet access

Step 1

required for this exercise:
ng Windows Vista

You will explore what happens when a service is stopped then started.

Log on to Windows as an administrator.

Click Start > Control Panel > Administrative Tools > Windows Defender.

Click Start > Control Panel > Administrative Tools > Computer Management > Continue > expand
Services and Applications > select Services.

Close the Administrative Tools window.

Resize and position both windows so they can be seen at the same time.

B wi

indows Defender

) @y Home ® Scan [+ B Histoy €3 Toos (2) |~

Protection against malicious and unwanted software

=
L\ﬂcmck for new definitions

Definitions allow Windows Defender to detect the latest
harmful or unwanted software and prevent it from running

View troubleshaoting tips on the web

+& Windows
... Defender

@Checkfer Updates Now

©ON your computer.

Status

Mot available
Daily around 2:00 AM,
Real-time protection: On

Last scan:
Scan schedule:

Definition version:

1.0.0.0 created on 7/13/2006 at 11:49 AM.

4 £8 storage
=] Disk Management

4 T Services and Applications
T Services
& WMI Control

] n +

Scan your computer for unwanted
software, schedule scans, and get the

Iatest unwanted software definitions, % Windows Driver F.. - Manages us..
G4 Windows Error Re...  Allows error...

L& Windows Event C...  This service ..

#3Windows Defender  Scan your c...

;5 Computer Management
File Action View Help
=2 1EEu=HEl»ann®
& Computer Management (Local ) Services
4 {1} System Tools '
& () Task Scheduler Windows Defender Name Description  Status Startup Type  Log On As &
¥ g i:ent;f::evlv;r &4 Windows Audio E..  Manages au., Started Automatic Local System
[+ 2] Shared Folders Stop the service T AT - il Wi Y'S
. k’ Local Users and Groups|| Restart the service il !nduw_ Backup Provides Wi... Manual Local System
" | indows CardSpa.. Securely en.. Manual Local System
i @ Reliability and Performa
i & Windows Color Sy.. The WesPlu.., Manual Lecal Service
i Device Manager - .
Description: C% Windows Cannect... Act as a Reg... Manual Local Service

Started Automatic Local System

Started  Automatic Local System

™

Started Automatic
Manual Metwork Service

Lacal System

Extended AStandard/
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Can Windows Defender check for updates?

Scroll the Computer Management window so you see the “Windows Defender” service.

& Computer Management ]
Start

File Action View Help

e e EIEEN IO :
ause

.*J Computer Management (Local |-  Services 5 ) Resume i |

'ﬁ’; System Tools

Stop

- Restart

b (3 Task Scheduler Windows Defender Name Description  Status e s i
v B v 2
P E:ent;f::ev:r C4 Windows Audio E..  Manages au... Started All Tasks b otem
[ @] Shared Folders Stop the service {w R 5 A
5 ék—' Local Users and Groups|| Restart the service ’,«‘, Windows Backup Provides Wi... Refresh em
; @ Reliability and Performe S Windows CardSpa.., Securely en.., em

4 Windows Color Sy... The WesPlu... Properties ice

Device Manager ey
a4 Description: ,.o,Wmdows Connect.. Actasz Reg...

4 £ Storage 5
i e _HEIP—-
(=] Disk Management software, schedule scans, and get the g \indows Defender _ Scan your c.._ Started

4y Services and Applications || latest unwanted software definitions, i Windows DriverF. Manages us... Started  Automatic Local System |
% Services % Windows Error Re...  Allows error...  Started Automatic Local System
& WMI Control 4 Windows Event C... This service ... Manual Network Service o

] 1t b | Extended /(Standard/

Stop service Windows Defender on Lecal Computer

What is the Status of the service?

Right-click Windows Defender service > select Stop.

Note: The reason this service will be stopped is so you can easily see the results. When stopping a
service, to free up system resources the service uses, it is important to understand how the overall
system operation will be affected.

The “Service Control” window opens and closes.

Select the “Windows Defender” window so it is active.

o Windows .[Z"eﬁ:nder

Home Scan | = History 4 & Tools {i} |= ‘. Wlndows
"W Defender

Protection against malicious and unwanted software

l@iewice has stopped

A problem caused this program's service to stop. To start the service, restart your computer or search Help
and Support on how to start a service manually.

Status
Last scan: Mot available
Scan schedule: Daily around 2:00 AM.
Real-time protection: On

1.0.00 created on 7/13/2006 at 11:42 AN,

Definition version:

What must be done so Windows Defender can run?
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What step must be followed to start the Windows Defender service?

Start the Windows Defender service.

ﬁ " =

© Computer Management

Help Start R}
Stop

File Action Vi

e |nEEoIHE >0 p =
‘EJ Computer Management (Local Reiing -
Fl '[i% System Tools
-~ Restart
& (@ Task Scheduler Windows Defender Mame Description  Status  Sta i
¥ E EventVicher . &k Windows Audio E.. Manages au... Started Ay All Tasks G
> @ Shared Folders Staittiesenice 2 Windows Backup  Provides Wi Ma
& & Local Users and Groups :QW S 5 , v Refresh
e | %k Windows CardSpa... Securely en... a
[ Relizbility and Peform i ~
@ 2 41 i Description: L4 Windows Color Sy.. The WesPlu.., Ma Properties
s Device Manager 5
@ o Scan your computer for unwanted 2% Windows Connect... Act as 2 Reg... Mz
4 =g Storage software, schedule scans, and get the W' N TS i Help
=1 Disk Manzgement Iatest unwanted software definitions. " i LY Ll
4 5‘& Services and Applications .?:.Winduws DriverF.. Manages us... Started Automatic Local System K
sﬁ Services ‘%Windnws Error Re..  Allows error..  Started Automatic Local System
ﬂ WMI Centrol f_..;Windows Event C... This zervice .. Manual Metwork Service i3
‘ m v\ Extended J Standard /

Start service Windows Defender on Local Computer

Select the “Windows Defender” window so it is active.

CJ Scan |- History {} Tools | ;.‘ 1 Windows

. Defender

Protection against malicious and unwanted software

@Chﬂ:k for new definitions

Definiticns allow Windows Defender to detect the latest [ @Check for Updates NOWEL
harmful cr unwanted software and prevent it from running View troublesheoting tips on the web
on your cormputer,

Status
Last scan: Mot available
Scan schedule: Daily arcund 2:00 AM.
Real-time protection: On
Definition version: 1.0.0.0 created on 7/13/2006 at 11:49 &AM,

Can Windows Defender check for updates?

Close the Windows Defender window.
Make sure the Computer Management window is open.
Expand Event Viewer > Windows Logs > select System.

Select the second event in the list.
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& &l Local Users and Groups
[3 @ Reliability and Performz

;gi Computer Management = EeR =<
File Action View Help
e=| 7K E
(& Computer Management (Loca 2 Level Date and Time Source EventID Task Category =
4 [f} System Tools ; " 2 B
(D) Task Scheduler @Im’ormatlon 12/13/2009 3:57:30 PM Service Control ... 7036 MNeone il
3 5
« [ Event Viewer ] Information 3/2009 3:47:51 PM Service Control ...
b [ Custom Views @Im’urmatiun F200% 3:41:35 PM Service Control .. 7035 Mene
4 [ Windows Logs ®Im’nrmatinn 12/13/2009 3:41:02 PM Service Control ... 7036 Mene
- ] Application @Im’urmatiun 12/13/2009 3:34:37 PM Service Control .. 7036 Mene
& Security = @Im’nrmatinn 12/13/2009 3:34:36 PI Service Control ... 7036 Mone -
E| setup Event 7036, Service Contral Manager Eventlag Provider x
[,:] System
. i:l Forwarded Even' General | Details
1+ [ Applications and Se A
[ Subscriptions The Windows Defender service entered the stopped state, B
> @ Shared Folders =

Leg Name: System
i Device Manager
. B i Source; Service Centrol Manager Eventlog Pre Logged: 12/13/2009 3:47:51 PM =
< 1 | 3

Look below the General tab then explain what has happened to the Windows Defender service.

Click the up arrow button on the keyboard or select the event above the one you just viewed.

A Computer Management

File Action View Help
e

[F=1 B o)

3‘- Computer Management (Loca + Event 1D
a m System Tools

[ @ Task Scheduler

Source

Service Control ... 7036

Level Date and Time

ﬂ- Information

Task Category

None

F @ ok i @Im’ormation 12/13/2009 3:47:51 PM Service Control .. 7036 Mene
b [ Custom Views @Infurmatlun 12/13/2009 3:41:35 PM Service Control ... 7038 Mene
4 [ Windows Logs @Im’ormation 12/13/2009 3:41:02 PM Service Control ... 7036 Mene
: Q Application ®Informat|on 12/13/2008 3:34:37 PM Service Control ... 7038 Nene
& Security = @Im’ormation 12/13/2009 3:34:35 PM Service Control .. 7036 Mene -
= vent , Service Control Manager Eventlog Provider
%z“;‘p Event 7036, Service Cantral Manager Eventlag Provid x
+| System

] Forwarded Even|

General | Detajls

p B Applications and 5e

;j Subscriptions
i» & Shared Folders
i & Local Users and Groups
& @ Reliability and Perform:

 The Windows Defender service entered the running state.

5 Log Name: Systermn
i Device Manager
. B Caian 52 Source: Service Control Manager Eventlog Pro Logged: 12/13/2009 3:57:30 PM -
< 1 | 3

Look below the General tab then explain what has happened to the Windows Defender service.

Close all opened windows.

Step 2
You will explore what happens when a service is stopped then started.

Navigate to the “Network and Sharing Center” window by clicking Start > Network and Sharing Center.
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5% » Control Panel » Network and Sharing Center - | "-| |Searrh Pl |

Network and Sharing Center

View computers and devices

" View full map
Connect to a network

Set up a connection or network 3*] hj"
e ..1

Manage network connections 9 =1
JOHN-PC Metwork Internet
Diagnose and repair (This computer)
5.‘ Metwork (Private network) Customize
Access Local and Internet
Connection Local Area Connection View status

m

|28 Sharing and Discovery

MNetwork discovery @ On @
File sharing @ Off Q_r)
Public folder sharing & Off @
Printer sharing < Off G:.l
Password protected sharing @ On l::\:f)
Seealso Media sharing @ Off Q_r)

Internet Options

g h Show me all the files and folders I am sharing
Windows Firewall 3 L4
Show me all the shared network folders on this computer

4

Click Manage network connections in the left pane.

Reduce the size of the “Network Connections” window. Leave this window open.

v|-@ <« Network Connections » v | 4 | |Search

B Organize ~ 2= Views ~

Name Status Device Mame Connectivity Network Category Owner »
LAN or High-5peed Internet (1) ~

P | Local Area Connection
r _ Metwork

Czd Intel(R) PROY1000 MT Metw...

Navigate to the “Control Panel” window by clicking Start > Control Panel.
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Control Panel Home

* Classic View

@T@v {#=| » Control Panel » - |‘, ‘ ‘ Search pe |
-
Marme Category  F2l
E ¢ b} Y
1 = Y
Add Administrativ. - AutcPlay  Backup and Color Date and Default Device
Hardware e Tools D,: Restore C... Management Time Programs Manager
e 3 » J i
[E % <=2
@ Fh® & y =
Ease of Folder Fonts Game Indexing Internet  iSCSIInitiator  Keyheard
Acce., Options Controllers  Options Options
LA ® 2 | 3
B )P/ y¥EE
Mouse Metwork and  Offline Files  Penand  People Near Performance Personaliz..  Phone and
Sharing Ce... Input Devices IMe Informatio... Modem ..
Y__- — B rz‘ =
L ) E D .
Pl = @
Power Frinters Problem Programs  Regicnal and Scanners and  Security Sound
Qptions Reports a..  and Features Language..  Cameras Center
e o 1 5 a
Speech Synec Center System TabletPC  Taskbar and Text to User VMware
Recogniti... Settings Start Menu Speech Accounts Tools
[y ~ 5= ETe. s - 4 > P M

Double-click the Administrative Tools icon.

The “Administrative Tools” window opens.

- |‘f| |Sean:b

B
oE v

‘ Organize ~

Favorite Links
E Documents
Ej Pictures
B Music

& Recently Changed
BB searches
Ju Public

Folders

~

Computer
IManagement

Print
Management

Size
Data Sources  Event Viewer  iSCSIInitiator
(ODBQ)
7 -
=
A
e 3
Reliability Services System
and Configurat..,
Performance
Monitor L\\?

n

Local Memory
Securi... Diagnosti...
/_-"-l_\)\

- q

Task Windows
Scheduler Firewall wi...

Shortcut

Reliability and Perfarmance Monitor Date modified: 1/20/2008 7:43 PM

Size: 1.58 KB
Date created: 11/2/2006 5:53 AM

Double-click the Reliability and Performance Monitor icon > Continue.

The “Reliability and Performance Monitor” window opens. Make sure the Performance Monitor in the left
pane is highlighted.
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@ Reliability and Performance
4 :i Menitering Tools
B8 Performance Monitor

E= Reliability Monitor
I 3 Data Collector Sets

[ :ﬁ Reports

Freeze Display (Ctrl+F) h

100
204
60+
404
20
o . .
1:32:42 PM 1:33:14 PM 1:33:44 PM 1:34:20 PM
Last | 5250 Average | 2301 Minimum 0,000
Maximum 38,063 Duration 1:40
Show Color Scale Counter Instance Parent  Object Computer

v

Click the Freeze Display icon to stop the recording.

Right click the Performance Monitor menu bar.

Relizb d

@ File Action View Favorites

Window Help

[

[ HEIR

ez 7E D HE

@ Reliability and Performance
4 [ Menitoring Teols
BE Peformance Menitor

TE- X CEBEX| PP E

== Reliability Menitor
2 3 Data Collector Sets

2 :ﬁ Reports

Add Counters..,

100 Save Settings As..
Save Image As...
a0 Save Data As...
Clgar
604 Zo®m To
Show Selected Counters
404 Hide Selected Counters
Scale Selected Counters
Remove All Counters
20
Properties...
0 |
1:32:42 PM 1:33:15 PM 1:33:45 PM 1:34:20 PM
[ 3 R — Average|  -eeemeee- Minimum|[ e
Maximum | —eeeeeee Duration | 1:40
Show Color Scale Counter Instance Parent  Object Computer

M ——10  %ProcessorTime  Total - Processor  WOHN-PC

Select Clear to clear the graph. Leave this window open.
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Navigate to the “Administrative Tools” window by clicking Start > Control Panel > Administrative Tools.

=1 | B |5

Organize ~

@(:\/)14 v Control Panel » Administrative Tocls

Se Views ~ [H Open (& Bumn

Esvarite Finks Name) Date medified Type
o B = E
£ ocuments { {1
o | s S o
E Pictures $ ER'*I
B Music Computer Data Sources  Event Viewer
@ Recently Changed Management (ODBC)
B5 Searches ﬁ; -
I
\, Public - il e
Print Relizhbility Services
Management  and Perfor... %
Folders ~
Services Date modified: 1/20/2008 7:43 PM
'“_ Shortcut Size: 1.64 KB
+ Date created: 11/2/2006 5:53 AM

v|"-| | Search

Size

iSCSI Initiator

System
Configurat...

Local
Securi...

Scheduler

Memo
Diagnosti...

Windows
Firewall wi...

2|

Iy

Double-click the Services icon > Continue.

Expand the width of the “Services” window so you have a clear view of the content. Scroll down in the

right pane until you see the service Routing and Remote Access.

,f Services ==
File Action View Help
e [EHBE o=z HE > =m0
_’,‘,} Services (Local) r_{' Services (Local)
Routing and Remote Access Name . Descripticn Status Startup Type Leg On As =
%4 Protected Storage Provides protect... Manual Local Syste...
Description: o M F: : 5 e .
Offers routing services to businesses ..( Quality Windows Audic Vid... Qual.lty\'.mdow... Manual Local Service
in local area and wide area network f; ReadyBoost Provides suppor.,  Started Automatic Local Syste..
envircnments, £ Remote Access Auto Conn..,  Creates a conne.., Manual Local Syste...
5 Remote Access Connection... Manages dial-u..  Started Manual Local Syste...
© Remote Procedure Call (RPC) Serves as theen... Started Automatic Metwork ... o
% Remote Procedure Call (RP... Manages the RP... Manual Network S... E
/ Remote Registry Enables remote ... Manual Local Service TH
"I Routing and Remote Access  Offers routing s... Disabled
f; Secondary Logen Enables starting ... Started Automatic Local 5 2
% Secure Socket Tunneling Pr...  Provides suppor.. Started IManual Local Service
£ Security Accounts Manager  Thestartup of t..  Started Automatic Local Syste...
4 Security Center Monitors syste...  Started Automatic (0. Local Service
ki Server Sunnorts file nri. Started  Aitomatic L acal Svste... i

Extended /(Standard/

Double-click Routing and Remote Access.

The “Routing and Remote Access Properties (Local Computer)” windows opens.
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Reuting and Remote Access Properties (Local Computer)

General | Log On | Recovery | Dependenciesl

and wide area network environments.

Path to executable:
CWindows aystem3Zevchost .exe ¢ netsves

Service name: Femotefooess
Dizplay name: Routing and Remote Access
Description: (Cffers routing services to businesses in local area

Startup type: Manual

Help me corfigure service startup options.

Service status: Stopped

Slop Faus

(k)
o
L
i

from here.

ou can specify the start parameters that apphy when you start the service

ok | [ cCancel || ﬁpph‘t\;

In the Startup type select Manual. Click Apply.

The Start button is now active; do not click the button yet. Leave this window open.

Position the following three windows so you can clearly see them at the same time: Network Connections,
Routing and Remote Access Properties (Local Computer), and Reliability and Performance Monitor.

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.
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O'O [ « Metwork Connections » [+ || secrcn »

Harne Statiss DevceMeme  Connectiity  Network Category  Ownes
LAN or High-Speed Intemet (1) -

L

Lecal Ares Conngction

g Rgliablg and Performance Moniter

@ File Actio

|5

4 [y Monitoring Tools
I Performance Monitor

View Favorites Window Help

== Reliability Monitor Add Counters... W
i+ [ Data Collector Sets 1 Save Settings As.
> [ Reports Save Image As...
80 Save Data As
Clgar
60 Zd®n To
Show Selected Counters
3 Hide Selected Counters
Scale Selected Counters
Remove All Counters
20
Properties..
|
1:3242PM 1:33:15 PM 1:3345 PM 1:34:20 PM
[ T —— [T E——
(YT I —— Duration | 140
Show Color Scale  Counter Instance Parent  Object Computer

Ml —— 10  %ProcessorTime  Total .- Processor  \WOHN-PC

General |Lng On I Recovery | Dependencies

Service name Remotefccess

Display name: Routing and Remate Access

Description: &rs routing services to businesses in local area &
nd wide area network environments.

Path to executable:
CAWindows'system 32\ svehost exe & netaves

Startup type: [Manua\ X

Help me configure service startup options.

Service status:  Stopped

I Start | | Stop | \ Pause | | Resume

*You can specify the startt parameters that apply when you start the service
from here

Start parameters: | |

Cancel | [ Appiy L\\J
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Click the “Reliability and Performance Monitor” window so it is activated.

@ Reliability and Performance Monitar .
@ File Action View Favorites Window Help B@E
e 2@ =0
4 [ Monitoring Tools = — :
P E - By | [
B8 Performance Monitor v | E:a x J | = = ! ||—[K' Dl] |
. &= Reliability Monitor Unfreeze Display (Ctrl+F) h
i+ [ Data Collector Sets 100
i [ Reports
50
0 T T
1:32:42 PM 1:33:15 PM 1:33:45 PM 1:34:20 PM
Last] @ ---—-- Average Minimum | --------
Maximurm | 1:40
Show Color Scale  Counter Instance Parent  Object Computer
¥ ——10  %ProcessorTime Total ---  Processor  \OHN-PC

Click the Unfreeze Display icon to start the recording.

Click the “Routing and Remote Access Properties (Local Computer)” window so it is activated. To start
the Service click Start.

A window with a progress bar opens.

F —1

‘Service Control @

Windows is attempting to start the following service on Local Computer.

Fouting and Remote Access

Cloze
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The “Routing and Remote Access Properties (Local Computer)” window now shows the Stop and Pause
button active. Leave this window open.

-

Reuting and Remote Access Properties (Local Computer) (==

General | Log On I Recovery I Dependenciesl

Service name: FemoteAccess

Display name: Routing and Remote Access

Diescrption: &rs routing services to businesses in local area -
nd wide area network environments. -

Path to executable:
CAWindows system32'svchost exe 4 netsves

Startup type: Manual Bt

Help me configure service startup options.

Service status:  Started

Start l Stop ] l Pause ] Resume

You can specify the start parameters that apply when you start the service
from hers.

Start parameters:

l 0K H Cancel ] Apply

Click the “Network Connections” window so it is activated.

f=lE ]

Search b |

{ )U " | @_‘F « Network Connections » - |‘f|

By Organize ~ F= Views ~

Mame Status Device Mame Connectivity Metwerk Category Chwner S
Inceming (1) A
&' Incoming Connecticns
r Mo clients connected
=22

LAN or High-5peed Internet (1) ~
: Local Area Connection

o Metwork

G Intel(R) PRO/1000 MT Netw...

Press function key F5 to refresh the content.

What changes appear in the right pane, after starting the Routing and Remote Access service?
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Click the “Routing and Remote Access Properties (Local Computer)” window so it is activated.

Routing and Remote Access Properties (Local Computer)

General | Log On | Recovery | Dependencies |

Service name: Remote Access

Display name: Routing and Remote Access

Description: ers routing services to businesses in local area -
nd wide area network environments. s

Path to executable:
C:\Windows'system 32\svchost .exe 4 netsves

Startup type: Manual -

Help me configure service startup options.

Service status: Started

Start ’ Stop l Fause ] Resume

You can specify the start parameters that apply when you start the service
from here.

Start parameters:

QK ] ’ Cancel Apply

Click Stop.

Click the “Network Connections” window so it is activated.

[F=1 [EoR )
§ "IU " | @‘ « MNetwork Connections » - |¥f| | Search o |

‘ Organize ~ Views =

Mame Status Device Mame Connectivity Metwerk Category Chwner S
LAN or High-5peed Internet (1) ~
c. Local Arez Connection

= Network

-~
@2 Intel(R) PRO/1000 MT Netw...

What changes appear in the right pane, after stopping the Routing and Remote Access service?

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.
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Click the “Reliability and Performance Monitor” window so it is activated.

i e e (=
@ File Action View Favorites Window Help ||T||E"?|
e A WS = | H &
4 :i Menitoring Tecls —
- En L4
B8 Performance Monitor 3 @ | # x ‘g | = I:I ! H!u ’I |
&5 Reliability Monitor e
. Fi Display (Ctrl
i+ [ Data Collector Sets 100 {eheeeze Display. (ChrlsB).§
[ :‘ﬁ Reports
50
2:02:03 PM 2:02:35 PM 2:03:05 PM 2:03:42 PM
Last 9.375 Average 15104  Minimum 1.563
Maximurm | 42,182 Duration | 1:40
Show Color Scale  Counter Instance Parent  Object Computer
¥ —— 10  %ProcesorTime  Total -~ Processor  \WOHN-PC

Click the Freeze Display icon to stop the recording.

Which Counter is being recorded the most in the graph (hint: look at the graph color and Counter color)?

Click the Change graph type drop-down menu, select Report.

& Reliability and Performance Menitor =]
@ File Action View Favorites Window Help ||T||E"?|

B e H @

4 :i Menitoring Tecls

B8 Performance Monitor “'Ellv” # x ‘g | = E| ! | LA |

B2 Reliability Monitor v Line
[ 3 Data Collector Sets 100+ Histogram bar
i [ Reports Report &

Ly

0 T .
2:02:03 PM 2:02:35 PM 2:03:05 PM 2:03:42 PM
Last 23438 Average 18950 Minimum 1.563
Maximurm | 08438 Duration | 1:40
Show Color Scale  Counter Instance Parent  Object Computer

¥ ——10  %ProcessorTime  Total -~ Processor  \OHN-PC

The display changes to report view.
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. @ Reliability and Performance Monitor .
@ File Action View Favorites Window Help BEE
e 2EE=H

4 [ Monitaring Tools

B Performance Moniter < [E v‘ E:a x ’ | 5 Ij !| D Dl”

B Reliability Monitor

i [y Data Collector Sets \WOHN-PC
g Reports Processor _Total
% Processor Time 23438

List the values of the counter.

Click the “Routing and Remote Access Properties (Local Computer)” window so it is activated.

Rbuting and Remote Access Properties (Local Computer) @

General | Log On | Recoveryl Dependenc:ies|

Service name: RemaoteAccess

Dizplay name: Routing and Remote Access

Description: &rs routing senvices to businesses in local area w
nd wide area network environments. L

Path to executable:
C i\ Windows'system32'\svchost exe 4 netsves

Startup type: [ Disabled i

Help me configurs service startup options.

Service status:  Stopped

Stop | Pause Resume

You can specify the start parameters that apply when you start the service
from hers.

Start parameters:

[ ok Q"H Cancel | [ Aoy |

In the Startup type select Disabled > OK.

Click the “Services” window so it is activated.
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=

File Action

View Help

e

% Services (Local)

Routing and Remote Access

Descripticn:
Offers routing se
in local area and
environments,

rvices to businesses
wide area network

o
Mare

":., Protected Storage

C.g ReadyBoost

£ Remote Access Auto Conn...
Sg Remote Access Connection... Manages dial-u...
ﬂ.y, Remote Procedure Call (RPC) Serves as the en...
i}, Remote Procedure Call (RP...  Manages the RP...
Enables remote ...

Se. Remote Registry

Routing and Remote Access

"'.,.., Secondary Legon

‘:‘, Security Accounts Manager

Sg Security Center

Ck Server

Description

Provides protect..,
ﬁ.g Quality Windows Audie Vid... Quality Window...
Provides suppor.
Creates a conne..,

Monitors syste...

Sunnorts file nri.

Offers routing s...
Enables starting ...
£ Secure Socket Tunneling Pr...  Provides supper...
The startup of t...

Status

Started

Started
Started

Started
Started
Started
Started
Starterd

Startup Type
Manual
Manual
Automatic
Manual
Manual
Automatic
Manual
Manual
Disabled
Automatic
Manual
Automatic

Automatic (D...

Aitnmatic

Log On As &
Local Syste..

Local Service

Local Syste..

Local Syste...

Local Syste...
Metwork S...

Network 5., El
Local Service

Local Syste...

Local Syste..

Local Service

Local Syste...

Local Service

| neal Suste...

Extended AStandard/

What is the Status and Startup Type for Routing and Remote Access?

Click the “Reliability and Performance Monitor” window so it is activated.

[=]=]x]

Eew|H =

[ :ﬁ Reports

@ Relizkility and Performance
4 [ Monitoring Teels
B8 Performance Menitor
B2 Reliability Monitor
3 :3 Data Collector Sets

& ||

| Unfreeze Display (Ctrl+F] L

100

50

2:02:03 PM

2:02:35 PM

2:03:05 PM

Last 23438 Average

Maximurm

18850 Minimum 1.563
98438 Duration 1:40

2:03:42 PM

Show  Color

Scale  Counter

Instance

Parent

¥ ——10  %ProcessorTime  Total - Processor  \WOHN-PC

Ohject

Computer

Click the Unfreeze Display icon to start the recording.

Close all open windows.

Navigate to the “Administrative Tools” window by clicking Start > Control Panel > Administrative Tools.
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= e e
o

- | 41| | Search

@70" v Control Panel » Administrative Tools

‘ Organize ¥ BB Views ~ (B Open (& Burn

Esvaiite Links Name/ Date modified Type Size
. 1 —_— = % P,
E Documents I /| Ly = 4 g
E Pictures I Ewl . g
B Music Computer ~ Data Scurces Event Viewer iSCSIInitistor Local Memory Print Reliability
Securi... Diagnosti.. Management and Perfor..,

& Recently Changed Management  (ODBC)

Searches o il Py i
Ealr g

Services Systemn Task Windows
Configurat..  Scheduler  Firewall wi...

Folders ~

. | Computer Management Date modified: 1/20/2008 7:43 PM
.& | Sherteut Size: 165 KB
i Date created: 11/2/2006 5:54 AM

Double-click the Computer Management icon > Continue.

The “Computer Management” window appears.

= e

;g; Computer Management
File Action View Help

&= |E =2 BE

A Computer Management (Local) Mame Actions
4 ]ﬁ %ﬂten1 Tools '[f‘l.!: System Tools Computer Management (Lo.. <
[ Task Scheduler é
4 @ B :LEStoragr: More Actions 14
T Services and Applications

[ @&l Shared Folders
i+ ¥ Local Users and Groups
[ @ Relizhility and Performance
s Device Manager
4 3 Storage
=¥ Disk Management
4 :??k Services and Applications
G Services

&5 WMI Control

4 1 3

Expand the three categories by clicking on the arrow next to: System Tools, Storage, and Services and
Applications.

Click the arrow next to Event Viewer then click the arrow next to Windows Logs.
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A Computer Management

File Action View Help
Rl A !
£ Computer Management (Local Level Date and Time Source EventID Task Category = Actions
4 [f} System Tools [ | syst
:’ (D) Task Scheduler () Information 7/28/2009 2:34:18 PM Service Cont... 7040 Mone ] S Sis
b g Event Viewer @Infurmatlon 7/28/2009 2:34:06 PM Service Cont.., 7036 Mone = Open Saved Log...
D # Custom Views %Infurmatmn 7/28/2009 2:33:53 PM Service Cont... 7036 Mone F Create Custom View...
g Information 7/28/2009 2:33:52 PM Service Cont... 7036 Mone
4 [ Windows Logs Import Custom View...
] Application () Information 7/28/2009 2:33:13 PM Service Cont.. 7036 Mone
2] Security (i) Information 7/28/2009 2:33:13 PM Service Cont... 7036 Mone Clear Log...
] setup (i) Information /28,2000 2:33:13 PM Service Cont... 7036 Mone F Filter Current Log...
EI System @Infurmatmn 7/28/2009 2:33:13 PM Service Cont... 7036 Mone D Properties
=| Forward¥d Evend ®Inﬁ:»rmatmn 7/28/2009 2:32:53 PM Service Cont... 7040 Mone 2
» [ Applications and Se| | (1) Information 7/28/2009 2:32:45 PM Service Cont... 036 None B8 Find..
[ Subscriptions (i) Information 7/28/2009 2:32:44 PM TBS 537 Mone <| | b Save Events As...
> g Shared Folders
% i Local Users and Groups| | ¥t 7040, Service Control Manager Eventlog Provider x Attach a Task To this L...
> @ Reliability and Performz| | [ General Det View
4 Device Manager 6| Refresh
4 25 Storage T
3 e start type of the Routing and Remote Access service was changed from demand start to Help
=5 Disk Management disabled.
> s Services and Applications Event 7040, Service Control ...
[Z] Event Properties
& Attach Task To This Ev...
Log Name: System 52 Copy
Source: Service Control Manager Eve Logged: 7/28/2009 2:34:18 PM fed Save Selected Events..
Event ID: 7040 Task Category: Mone Gl Refresh
Level: Information Keywords: Classic Help
User: John-PC\ohn Computer John-PC
OpCode: Info
More Information:  Event Log Online Help
< . +
Select System.
Double-click the first event in the window.
A Computer Management
File Action View Help
|
& Computer Management (Lecal [ | | Date and Time Source EventID Task Category | | Actions
a [k System Tools A [ Sysiem -

> (5) Task Scheduler

4 (@] Event Viewer @Informatlon 7/28/2009 2:34:06 PM Service Con 7036 None
GirstomAiews @Informatlon 7/28/2009 2:33:53 PM Service Cont... 7036 None
Windows Logs @Informatlon 7/28/2009 2:33:52 PM Service Cont... 7036 Mone

h ] Application (@) Information 7/28/2009 2:33:13 PM Service Con 7036 Mone

%;‘ Security (DIm’ormation 7/28/2009 2:33:13 PM Service Cont.., 7036 MNone

] Setup (@) Information 7/28/2009 2:33:13 PM Service Cont... 7036 None

& System ®Infnrmation 7/28/2009 2:33:13 PM Service Cont... 7036 Mone

5] Forwarded Even ®Inﬁ)rmation 7/28/2009 2:32:53 PM Service Cont... 7040 Mone

1 (1 Applications and Se @Infurmatiun 7/28/2009 2:32:45 PM Service Cont... 7036 None
Subscriptions @Inﬁ:rmatlon 7/28/2009 2:32:44 PM TES 537 Mene

1 | Shared Folders

» @ Local Users and Groups Event 7040, Service Control Manager Eventlog Provider

- @ Reliability and Performz m‘m‘
4 Device Manager
4 5 Storage [The start type of the Routing and Remote Access service was changed from demand start to
= Disk Management rahledt
> s Services and Applications
Log Name: System
Source: Service Control Manager Eve Logged: 7/28/2009 2:34:18 PM
Event ID: 7040 Task Category: None
Level: Information Keywords: Classic
User: John-PC'ohn Computer: John-PC
OpCode: Infa
More Information:  Event Log Online Help

7% Open Saved Log...

¥ Create Custom View...
Tmport Custom View...
Clear Log...

Filter Current Log...
Properties

Find...

O E @

Save Events As...
Attach a Task To this L.
View 3

Refresh

B

Help »
Event 7040, Service Control ...
Event Properties

Attach Task To This Ev...
Copy 3
Save Selected Events...

Refresh

Bp O EE

Help »

The “Event Properties” window opens for the event.
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Click the down arrow key to locate an event for Routing and Remote Access.

General | Details

{2l Event Properties - Event 7040, Service Control Manager Eventlog Provider

disabled.

Log Mame:
Source:
Event ID:
Level:

Usen
OpCode:

More Information:

The start type of the Routing and Remote Access service was changed from demand start to

Systermn

Service Control Manager Eve Logged: 7/28/2009 2:34:18 PM
7040 Task Categony: MNeone

Infermation Keywords: Classic
John-PClohn Computer: John-PC

Info

Event L og Online Help

Close

=5

You should find four events that describe the order for starting and stopping the Routing and Remote

access service.

Write down the description for each of the four events.

General | Details

12 Event Properties - Event 7040, Service Control Manager Eventlog Provider

start.

Log MName:
Source:
Event ID:
Level:

User:
OpCode:

More Information:

System

Service Control Manager Eve Logged:

7040 Task Category:
Information Keywords:
John-PC\John Computern:
Info

Event Log Online Help

The start type of the Routing and Remote Access service was changed from disabled to demand

1/28/2009 2:32:53 PM
Mone

Classic

Jehn-PC

() [+

Close

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.
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General | Details

@ Event Properties - Event 7036, Service Control Manager Eventlog Provider

The Routing and Remote Access service entered the running state.

Log Name:
Source:
Event IC:
Level:

User:
OpCode:

More Information:

System

Service Control Manager Eve Logged:

7036 Task Category:
Information Keywords:
MN/A Computer:

Info

Event L og Online Help

1/28/2009 2:33:13 PM
MNone

Classic

John-PC

[« &

Close

General | Details

@ Event Properties - Event 7036, Service Control Manager Eventlog Provider

The Routing and Remote Access service entered the stopped state.

Log Name:
Source:
Event ID:
Level:
User:
OpCode:

More Information:

System

Service Control Manager Eve Logged:

7036 Task Category:
Information Keywords:
MfA Computer:

Info
Event Log Online Help

7/28/2009 2:34:06 PM
Mone

Classic

John-PC

[«) [#]

Close

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.

Page 20 of 33



IT Essentials

Chapter 5 Lab

General | Details

Event Properties - Event 7040, Service Control Manager Eventleg Provider

disabled.

Log Name:
Source:
Event IC:
Level:

User:
OpCode:

More Information:

System

Service Control Manager Eve Logged:

7040 Task Category:
Information Keywords:
John-PC\John Computer:
Info

Event L og Online Help

The start type of the Routing and Remote Access service was changed from demand start to

1/28/2009 2:34:18 PM
MNone

Classic

John-PC

Copy

Close

Close all open windows.

Step 3

For the rest of this lab, you will configure advanced Administrative Tool features and monitor how this
affects the computer system.

Click Start > Control Panel > Administrative Tools > Reliability and Performance Monitor >

Continue.

The “Reliability and Performance Monitor” window opens.
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@ Reliability and Performance Monitor

@ File Action View Favorites
L
@ Reliability and Performance

4 [ Monitoring Toals

Nindow  Help &%

Resource Overview (=

1 MB/sec

Metwork 10 Mbps

Performance Monitor CPU 100% Disk Memory 100 Hard ...

== Reliability Monitor
:‘- Data Collector Sets
[ Reports

&0 Seconds 0%

0 0
| CPU M 3% |77 100% Maximum Frequency |'\; ] |
| Disk B 0 KB/sec M 0% Highest Active Time |\: |
| Network B 0 Mbps W 0% Network Utilization (x) |
| Memory . 0 Hard Faults/sec F 32% Used Physical Memary |\: |
Learn More (=

* Resource View Help
« Performance Manitor Help

« Data Collection Help

« Create a Data Collector Set and Diagnosis Repart
+ Maonitor System Activity with Performance Monitor

« Schedule and Manage Data

Expand Data Collector Sets.

@ Reliability and Performance Monitor

Create a new Data Collector 5et,

@ File Action View Favorites Window Help —[|&] =
|
@ Reliability and Performance = e
x Resource Overview ()
4 L Monitoring Tools :
Performance Monitor CPU 100% Disk Metwork 10 Mbps Memory 100 Hard ...
== Reliability Monitor 1
4 :'-_ Data Collector Sets
2, User Defined
1 Mew
< Mew Window from Here
2 ol 0 0
ok Refresh
7% 100% Maximum Frequency |';.- |
el W 7 I 1005 ©
| Disk B 0 KB/sec W 0% Highest Active Time |\: |
| Network B 0 Mbps W 05 Netwark Utilization (x) |
| Memory . 0 Hard Faults/sec F 33% Used Physical Memory |\: |
Learn More (=)
* Resource View Help « Create a Data Collector Set and Diagnosis Repart
« Performance Manitor Help + Maonitor System Activity with Performance Monitor
« Data Collection Help « Schedule and Manage Data
4 ; 0 b

Right-click User Defined > New > Data Collector Set.

The “Create new Data Collector Set” window opens.
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'\____,)' @ Create new Data Collector Set.

How would you like to create this new data collector set?

Mame:

Memoary Logs

71 Create fram a template (Recommended)
How do I work with templates?

@ Create manually (Advanced)
How do I choose data collectors manually?

Finish Cancel

In the Name field, type Memory Logs. Select the Create manually (Advanced) radio button > Next.

The “What type of data do you want to include?” screen appears.

F-

@ @ Create new Data Collector 5et.
What type of data do you want to include?

@ Create data logs

| Performance counter

|| Event trace data

|__: System canfiguration infarmation

) Performance Counter Alert

[ Meda [\ [ Finish | [ Cancel

Select Performance counter > Next.

The “Which performance counter would you like to log?” screen appears.
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@ @ Create new Data Collector Set.
Which performance counters would you like to log?
Perfarmance counters:
Add.,
Remaove
Sample interval: Units:
s :
[ Net || Finish || Cancel
Click Add.
From the list of available counters locate and expand Memory.
Available counters Added counters
St T e T Counter Parent Inst. Computer
<Local computer > -
Job Ubject Uetails e
Legicallisk v
Memery ~
% Committed Bytes In Use I:l
Available Bytes
Available KBytes
Cache Bytes
Cache Bytes Peak hd
Instances of selecte
Search
[ Show description Help ] [ o J [ Cancel

Select Available MBytes > Add.
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Awailable counters Added counters
Select counters from computer:
Counter Parent Inst... Computer
<Local computer> -
Memory ~

Job Ubject Detalls by Available MBytes

LogicalDisk hd

Memory -

% Committed Bytes In Use I
Available Bytes
Available KBytes
Available MBytes
Cache Bytes
Cache Bytes Peak

[ Show description

Help ] [ OK %J [ Cancel

Click OK.

Set the Sample interval field to 4 seconds.

@ @ Create new Data Collector Set.

Which performance counters would you like to log?

Perfarmance counters:

‘Memary\Available MEBytes Add..

Remave

Sample interval: Units:

ﬂ = Seconds -

[ NNL\J[ Finish | | Cancel

Click Next.
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The “Where would you like the data to be saved?” screen appears.

P

@ @ Create new Data Collector Set,
Where would you like the data to be saved?
Root directony:
Browse..|\
[ Ned || Finish || Cancel
Click Browse.
22 |

@ @ Create new Data Collector Set.

Browse For Folder (3]

Where v select a root path for the collected data.

Bk 1M Computer =
Sesystem - & Floppy Disk Drive (4:) (W Browse...
F] & Vista_Business ()

| Ch12

| PerfLegs

| Program Files

m

 Users
» g Windows
» = Local Disk (D)
£ DVD BW Dirbec (Y

Make Mew Folder ] [ OFK [}J[ Cancel ]

[ Ned || Finish || Cancel

Select drive (C:) > Make New Folder > type PerfLogs > OK.
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The “Create new Data Collector Set” window appears.

@ @ Create new Data Collector Set.
Where would you like the data to be saved?
Root directory:
ChPerflogs
[ Next 'D\J | Finish | [ Cancel
Click Next.

@ @ Create new Data Collector Set.
Create the data collector set?
Run as:

) Open properties for this data collector set
() Start this data collectar set now

@ Save and clase

lext I Finish%J[ Cancel

Click Finish.
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Expand User Defined > select Memory Logs > right-click Data CollectorO1 > Properties.

@ Reliability and Performance Moniter

f=di= s
@ File Action View Favorites Window Help !___—!LEL"_?J
e | 2@ XE = |HE
@ Reliability and Perfermance
a i Manitoring Tools
BE Performance Monitor
= Reliability Menitor
4 _:1-) Data Collector Sets
4 _,B Uszer Defined
¥ Memory Logs
b [y System

Mame

Type Output
Performance Counter

DataCollector(l

_iz| Event Trace Sessions
: |z Startup Event Trace Se
[ ]j Reports

N M | ko]

(T r
Opens the properties dialog box for the current selection,

The “DataCollector01 Properties” window opens.

DataCellectordl Properties

Performance Counters |FiIE |

Performance counters:

Memory\Available MBytes Add. ..

Remave

Log format:

Einar: -

Comma Separated

Tab Separated * Units: [ Masdimum samples:
SQL

Binary W 0 [Ea]

Data source name:

4

[ QK ][ Cancel ] Apply

Change the “Log format:” field to Comma Separated.
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Click the File tab.

o '\.

DataCollecterll Properties [mE3m])

Performance Counters | File |

Log file name:
DataCollectardl

File name format:

(] Prefix file with computer name

Log mode

|:| Owerwrite

Hppend

Example file name:
C:\PerfLogs\00000 1'DataCollectord 1. csv

’ QK !}’H Cancel H Apply H Help

What is the full path name to the example file name?

Click OK.

Select the Memory Logs icon in the left pane of the “Reliability and Performance Monitor” window.
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@ Reliahility and Perfermance Monitor =) E )
@ File Action View Favorites Window Help = :.5‘._.)(-
s E XDz BHmlpmad

@ Reliability and Performance Name e

: Type Output
4 | g Monitering Tools . [E]DstaCollectordl
B8 Performance Menitor

E= Reliability Monitor
P 3 Data Collector Sets
a [3 User Defined

7 Memory Logs

Performance Counter

s Cag System
& Event Trace Sessions
:ﬁ. Startup Event Trace Ses
- [ Reports

< mm | 3

n

Click the green arrow icon to start the data collection set.

@ Reliability and Performance Maonitor =] =)
@ File Action View Favorites Window Help = '3.5‘ .:x-
e | EIXED o= HE PR
@ Reliability and Performance
4 L Monitoring Tools [Z]DataCollectoril Performance Counter

B8 Performance Menitor

B2 Reliability Monitor
a [ Data Collector Sets

4 E, User Defined

& Memory Logs

> D 5}'{/\\3““
,‘-o; Event Trace Sessions

i5] Startup Event Trace Ses
i [ Reports

Mame Type Output

C\Perflogs\000001' DataCollectorl.csv

4 I

I

To force the computer to use some of the available memory, open and close a browser.
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@Reliahilit}randParFormanceMomtor
@ File Action View Favorites Window Help

XEoos Hm bmME
@ Reliability and Performance “
4 Ly Monitoring Tools
BE Performance Monitor
B Reliability Monitor
a \‘j Data Collector Sets
a [ User Defined
o Memory Logs
b Caa System

Mame

Type Output
DataCollectordl

Performance Counter CPerflogs\000001%DataCollectorl . csv

\L Event Trace Sessions
&‘ Startup Event Trace Ses
i g Reports

I

Click the black box icon to stop the data collection set.

What change do you notice for the Memory Logs icon?

@ Reliability and Performance Maonitor
@File Action  View Favorites  Window  Help

e | HEXEe= HEI PEAE

@ Reliakility and Performance
4 [ Monitoring Tools
B8 Performance Menitor
E= Reliability Monitor

4 _\‘1; Data Collector Sets

4 3 User Defined
W Memory Logs

Mame

Type Output
DataCollectordl

Performance Counter C\Perflogs\000001' DataCollectorl.csv

» O S}L\\gem
:-ﬁ‘ Event Trace Sessions
1‘-\,3 Startup Event Trace Ses
i [ Reports

] 1 | k]

I
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Click Start > Computer > double-click drive C: > PerfLogs > 00001 > Continue.

E=H(HcE 55

.
@uv| , v Computer » Vista_Business (C:) » Perflogs » 000001

‘ Organze ~ ™ Views ~ (g Bumn

Eavarelinkis Name Date modified Type Size
EE. Documents

EE Pictures

EI_J' Music

|# Recently Changed :

More DataCollectorll

Folders ~

1 item

v |"9 | | Search

ol

Double-click DataCollector01 text file.

s

| DataCollectord] - MNotepad [ [= ][]
File Edit Format View Help

"{PDH-C5V 4.0) {(Pacific standard Time) -
(480)", "\ \COMPUTERL'\Memory“Available MBytes" 5
"12/14/2009 18:28:35.016","1012"

"12/14/2009 18:28:38.937","1012"

"12/14/2000 18:28:42.937","1012"

"12/14/2009 18:28:46.937","1012"

"12/14 /2009 18:28:50.937","1012"

"12/14/2009 18:28:54.937","1008"

"12/14/2009 18:28:58.937","1008" E
"12/14/2009 18:29:02.937","1005%"

"12/14/2009 18:29:06.937","1007"

"12/14/2009 18:29:10.937","1007"

"12/14/2000 18:29:14.937","1007"

"12/14/2009 18:29:18.937","1007"

"12/14 /2009 18:25:22.937","1007"

"12/14/2009 18:29:26.937","1007" ==
"12/14/2009 18:29:30.937","1008"

"12/14/2009 18:29:34.937","1008"

"12/14/2009 18:29:38.937","1008"

"12/14/2009 18:29:42.937","1008"

"12/14/2009 18:29:46.937","1008"

"12/14/2009 18:29:50.937","1010"

"12/14 /2009 18:29:54.937","1010"

"12/14/2009 18:29:58.937","1010" i

-

What does the column farthest to the right show?

Close the DataCollector01 text file and the window with the PerfLogs folder.

Select the Reliability and Performance Monitor window.

© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public.

Page 32 of 33



IT Essentials Chapter 5 Lab

@ Reliability and Performance Monitor EI@
@ File Action View Favorites Window Help - |2 %
e | 7EHXEo=z HE PEAE
@ Reliability and Performance Name Type Output
4 lgm Monitoring Tools . [ DataCollectordl Performance Counter C:\PerfLogs\000001DataCellecto
B8 Performance Monitor
== Relizbility Moenitor
4 [ Data Collector Sets
a [ User Defined
¥ Memory Legs
> [ System Start
i Event Trace Sessi 5
— Stop
1) Startup Event Tra
. [y Reports Save Template...
Data Manager...
Latest Report
MNew 3
View 3
Mew Window from Here
MNew Tas